0
$\begingroup$

I am trying to set up a noise texture that will be used as a mask, therefore to be used as non-color data. I am previewing the texture by connecting it to the material output without passing through a BSDF (although under the hood I think it's using an Emission BSDF). Unfortunately, my previews are affected by color management and prevent me from seeing the full range of values:

  1. The 3d viewport in material preview is affected by the "View Transform" and "Look settings"
  2. The preview in the material tab seems to be using rendered mode and is not only affected by the same 2 settings, but further by the exposure and gamma settings.

As you can see on the example setup below, the only way I found to preview my texture linearly is to keep switching these 4 render settings anytime I need to preview non-color data. I want to preview the pure whites and pure blacks that are in my color ramp without having to do that each time. Is there another way? I noticed that also happens when you try to preview an image picture set to non-color data.

Example setup

$\endgroup$
3
  • 1
    $\begingroup$ fyi the 'Linear' you highlighted in the Color Ramp node controls the blending curve between one keyed colour to another. It's like an animation curve, and has nothing to do with colour space. $\endgroup$
    – coCoKNIght
    Commented May 4 at 16:58
  • 1
    $\begingroup$ another thing to note is that linear colours always need to be interpreted in some way in order for you to see them on your screen. If you just want to check whether the values in the texture have reached pure black and pure white, then one approach might be to add a reference geometry with pure black and pure white behind your cube for comparison. It will be equally affected by any colour transformations. $\endgroup$
    – coCoKNIght
    Commented May 4 at 17:10
  • $\begingroup$ @coCoKNIght thank for for taking the time to reply. I'm not sure I understand what you mean, or maybe I wasn't clear. I wasn't highlighting linear, I was highlighting the pure white as a comparison, this is the color expected on the cube, but it shows as grey. I don't need to compare, I can well in both previews that the pure white is not showing. I'm asking how can I show preview it without every switching my colour management settings back and forth. $\endgroup$
    – buttr_toes
    Commented May 6 at 16:56

2 Answers 2

1
$\begingroup$

Try using Solid Viewport Shading with the following settings. With this, colour management settings will have much less impact on the display of your texture in the 3D Viewport.

viewport shading

$\endgroup$
4
  • $\begingroup$ Sorry for the late reply and thank you again for taking the time. Unfortunately that doesn't work in my case, since it seems the "texture" option only works for image texture, whereas I am using a procedural noise texture. $\endgroup$
    – buttr_toes
    Commented May 21 at 14:45
  • $\begingroup$ You're right, I didn't realize that it only works with image textures, sorry about that. I'm afraid, I'm out of ideas for now. Maybe if you could provide more detailed information about why you want to do this? I don't fully understand why this is an issue for you or how you're using this workflow for what purpose. $\endgroup$
    – coCoKNIght
    Commented May 22 at 13:10
  • $\begingroup$ It's an issue for me because I'm using the noise texture as non-color data (displacement, shifting coordinates, etc.). If I cannot see the full range from black to white on the model and if it doesn't match the color ramp, it's kind of hard to see what the effect will be and makes it hard to adjust precisely. My color ramp is showing me one range and the output shows me another one. What parts of my model have a value of 1 if I cannot see pure white? Maybe I'm thinking about it wrongly. Thanks again for taking the time :) $\endgroup$
    – buttr_toes
    Commented May 23 at 23:43
  • $\begingroup$ The only way to identify whether something is pure white (1) or pure black (0) in the viewport is by comparison. That's why earlier I suggested that you add a reference geometry behind your cube, or 2, one black and one white. Then you will see by comparison what parts of your noise texture have reached full black or full white. And you will be able to do this no matter what you setup under color management, because the reference geometries will be affected equally. $\endgroup$
    – coCoKNIght
    Commented May 25 at 14:25
1
$\begingroup$

To illustrate the point from my previous comment:

enter image description here

Here I've added two planes to the back of the cube. I've set one plane to black (without passing through BSDF) and one plane to white.

So now I know, if the black from the noise texture on the cube reaches the black level of the plane behind it, then it's completely black. Similarly I can compare the white parts of the noise texture with the white of the plane to see what parts of the noise texture have reached a value of 1 (completely white).

When I change my color management settings, then all colours change, but the reference is still valid and I can see the full range of colours nevertheless:

enter image description here

(Here I've changed colour management view transform to Raw)

Having said that, Raw is probably a better representation of how the values in your noise texture will affect your material when used as a mask and switching-up material settings or colour management settings in order to fine-tune certain details is a common practice.

$\endgroup$
1
  • $\begingroup$ Thank you for taking the time to help me find a solution. I guess I was looking for a quick way to preview non-color data as non-color data without having to fiddle each time with color transforms, and this is not implemented. Thanks again for the workarounds provided! $\endgroup$
    – buttr_toes
    Commented Jun 13 at 21:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .