15
$\begingroup$

I'm trying to make some procedural textures that will give me a result like this:

this -

this one is said to have been a voronoi + a clouds texture and I figured the best way to combine those is to use the node editor for Textures and then just slap that Texture that I create in the node editor as the Texture I use in the Displace Modifier pane.

The thing is, for some reason, when I select my Texture in the Displace modifier (for which I have already setup the nodes) as you can see here

here, it doesn't actually affect the plane at all, as you can see

here.

When I go over to the Textures tab, it shows the preview that is output from the node editor

http://imgur.com/9ieRinj

but the Displace Modifier isn't having any of it...

Any ideas? I tried looking online but everything was either on baking normal maps or they didn't use the node editor for the Displace Modifier - they just used the default cloud textures or whatever.

Thanks so much!!

$\endgroup$
  • $\begingroup$ Cycles procedural textures are computed by cycles at render time and are separate from blender's textures. The displace modifier uses blender textures. To mix blender textures you could use multiple displace modifiers. Or if you want to use cycles textures, you could use cycles displacement: $\endgroup$ – gandalf3 May 30 '15 at 3:36
  • $\begingroup$ Oh, I thought you were using cycles nodes. My bad. I've edited your question to clarify it a little, though It's my own fault for mis-reading it in the first place :) As to why texture nodes don't work, I don't know. Texture nodes is one of those ancient parts of blender which doesn't work with very many other parts, so I'm honestly not terribly surprised.. But I can't think of a logical reason why this would be the case. $\endgroup$ – gandalf3 May 30 '15 at 5:46
  • $\begingroup$ You have the Sub-division modifier below the Displace modifier which means that the Displacement is happening before the subdivision. If the plane is not already subdivided in Edit mode then it is only one face so far as the Displace Modifier is concerned and this will not work. $\endgroup$ – MarcClintDion May 30 '15 at 13:51
  • $\begingroup$ @MarcClintDion - sorry forgot to mention that I did subdivide it, like 4 times $\endgroup$ – gogonimago Jun 2 '15 at 16:44
  • 1
    $\begingroup$ I don't think is possible @Gunslinger, apart from that WIP video from the developer I hadn't seen anything about it yet, not even a costum build to try it out. Maybe they are planning a complete rebuild of the node code befor releasing something. For your project, consider that after all you just have to provide an image texture to the displace modifier. Using node would really help you in building the texture "on the fly", but the final result would be the same as if you composite several textures in an external editor or bake the heightmap coming out from the cycles displacement (see below). $\endgroup$ – Carlo Jun 1 '16 at 20:53
10
$\begingroup$

It'd be nice if this worked, however as an alternative you might consider using cycles displacement.

Here's a simple example of what's possible. This scene is made up of one plane, with no displace modifier:

enter image description here

enter image description here

Note that it's an experimental feature, so you'll have to enable experimental features first, and you may encounter bugs. If you do find a bug, report it and chances are it will be fixed :)

$\endgroup$
  • $\begingroup$ Thank you! I'm sorry but I don't seem to understand how to use this feature - what is the difference between it and simply plugging nodes into the "Displacement" input on the output node? If you turn on Experimental mode, does it automatically turn on? I can make my mountains with the displacement input on the material output but I'm not sure what part the experiential displacement feature plays in all this... $\endgroup$ – gogonimago Jun 2 '15 at 17:17
  • $\begingroup$ @gogonimago Normally the displacement output just does some bump mapping. But when experimental features are enabled and the bump type is set to True or Both, cycles will actually displace the object's surface using the displace input. See this answer for more detail: blender.stackexchange.com/a/15478/599 $\endgroup$ – gandalf3 Jun 2 '15 at 19:19
  • $\begingroup$ gotcha - so it works in conjunction with the Displacement output. Ok, yeah, it works like a charm, thanks! $\endgroup$ – gogonimago Jun 2 '15 at 20:22
0
$\begingroup$

For anyone else googling this like myself, the experimental true displacement does not work on large meshes. If you scale something to say 10,000 km for real scale (say a planet), in a km unit scene ofc, and apply the resize/scale then true displacement stops working. Or if you newly apply true displacement after applying a large scale, it still won't work at all. Blender 2.79

$\endgroup$
  • 1
    $\begingroup$ Out of interest, I've tried this in Blender 2.76b with a 13000km planet using true displacement and it seemed to work fine. It may be that it's broken at 2.79 or it may be something in your setup. I believe the displacement is in 'blender units' so if you're in Metric then each '1' fed into the displacement would represent 1m. For a 13,000km planet I had to multiply up the displacement by a factor of 2,500,000! See imgur.com/a/CJjo9 $\endgroup$ – Rich Sedman Oct 26 '17 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.