New to blender, please bear with me.

Created a face from multiple objects, then joined them with ctrl + j. Things went wrong, wanted to edit the individual objects again, so unjoined by separating by loose parts.

Duplicated this new collection.

For both collections, the pivot point seems to be locked to the world origin (see image). Shift + S setting cursor to origin then Shift + S again Selection to Cursor does nothing. Tried alt + p to clear parent, that didn't seem to do anything either.

Additionally, when I drag any individual object within each collection, each entire collection moves proportionally to one another.

I've also tried changing the pivot point to median, as suggested here (why aren't move parameters staying with object), but that didn't work.

I suspect I've bungled something royally along the way, but can't seem to figure it out. image of problem


1 Answer 1


Solved. Selected the object then in upper left tab option "Object" selected Set Origin -> Origin to Geometry

Still unclear how I got to that point however, but posting in case anyone else has this issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .