i'm trying to fill "pools" with water particles ( fluid ) to make a splash simulation with fluid. My problem is that the mesh i use is not filled entirely resulting in empty borders between water pool and the landscape. i tried almost all parameters in fluid domain , increased resolution etc etc, did not work. Is the problem coming from the shape of the mesh im trying to fill?

What am i missing ?


Blend file here

thank you

  • $\begingroup$ is 150 really the highest resolution you tried? because i am pretty sure it is the resolution...and of course you have to increase subdiv of your "pool" as well, if this isn't enough. i tried with 300....[1]: i.sstatic.net/7A6sQpEe.png and as you can see it is in fact getting better. So i wonder what you really have tried.... $\endgroup$
    – Chris
    Commented Apr 13 at 3:48
  • $\begingroup$ i tried 300, i tried 500. Doesnt change anything it just increases the amount of particles but still there is an empty space not filled. Also my computer hardly supports more than 150 thats why i set it at this value for now. I also exported the "pool" as a fbx into houdini to try in another software. it does almost the same thing or i have to increase the resolution to an insane amount that my computer cant handle. $\endgroup$
    – ant0
    Commented Apr 13 at 4:01
  • $\begingroup$ @Chris 500 resolution here a screenshot of 500. $\endgroup$
    – ant0
    Commented Apr 13 at 4:27
  • $\begingroup$ @Chris No, I don't think it's the resolution. It's probably another one of many Mantaflow bugs. Just making it a manifold mesh and switching off Is Planar solves the problem even at a low resolution of ~100 (In my attached example in the answer), and I believe something around ~175-200 would give the OP a perfect result. $\endgroup$ Commented Apr 13 at 9:58
  • $\begingroup$ @Chris I did the same process using FLIP FLUIDS (It is kind of available for free, however, the free, not demo, version doesn't provide you with the materials etc) and was going to post that as the best solution to this, however, I just quickly switched to a low-res bake in Mantaflow and it worked just as well $\endgroup$ Commented Apr 13 at 10:01

1 Answer 1


Simply go to edit mode and go to Select > Select All by Trait > Non Manifold

enter image description here

Next, press E to extrude the mesh, press Z to lock it to the Z-axis, and move it down until it is not intersecting with itself. Then press F to fill.

enter image description here

Now, you can uncheck Is Planar in its effector settings and bake your simulation again.

enter image description here

The most probable reason for a gap between the fluid and the collision object is Blender setting a default value for the Surface Thickness value in the effector settings when set to 0 and Is Planar. Since this is not documented, I take it to be a bug in the Mantaflow simulator.

  • $\begingroup$ it worked perfectly now the fluid sim fills the border, thank you so much. $\endgroup$
    – ant0
    Commented Apr 13 at 15:50
  • $\begingroup$ @ant0 Good luck with your project! :) $\endgroup$ Commented Apr 13 at 18:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .