1
$\begingroup$

enter image description hereCan someone explain this? I cant see how to control shadows from lights in Viewport Shading mode... There is some wierd other light source... Also, in Material preview and Render, the "Scene world" button is backwards, its on when unchecked and off when checked.. Opposite to "Scene Lighting"....frustrating.... by the way how does one add a video on here to show screen capture... I can only add images... VIewportshading shadows?

$\endgroup$

1 Answer 1

1
$\begingroup$

In Rendered preview, the Scene Lights and Scene World options are enabled by default. They will let you see the effect of the lights you've created in your 3D scene and the effect of the HDRI or background that you've chosen for your World, if they are disabled you'll see no light effect and you'll see the effect of the HDRI chosen in the Viewport Shading panel.

In Material preview the Scene Lights and Scene World options are disabled by default. You'll see the effect of the HDRI that is chosen in the Viewport Shading panel. If you enable them you'll see the effect of the HDRI or background that you've chosen for your World.

As for the Solid mode, it won't take your 3D scene lights into account, you can still create a shadow effect if you enable the option in the Viewport Shading panel, as if you had a virtual light. In order to control this shadow you need to click on the small gear icon and play with the ball:

enter image description here

$\endgroup$
5
  • $\begingroup$ HI moonboots, thanks for your reply. this shadowing setting is for the object, not the scene. The ´cast´shadows is what im reffering to. This is a new file, no HDRI loaded in World. the buttons the Scene Worldbutton is backwards... I have a screen capture video to show it but cant figure out how to post it... $\endgroup$
    – Tony Sands
    Apr 6 at 20:02
  • $\begingroup$ screenrec.com/share/PUmNRiEjuG $\endgroup$
    – Tony Sands
    Apr 6 at 20:20
  • $\begingroup$ I've edited my answer, I hope this is more clear? $\endgroup$
    – moonboots
    Apr 7 at 8:16
  • $\begingroup$ Hi moonboots, Thanks for taking the time to explain that. I appreciate it! That makes sense now. I guess the Solid view is a bit strange or not exactly helpful in regards to PROJECTED shadows. $\endgroup$
    – Tony Sands
    Apr 7 at 11:41
  • $\begingroup$ the shadow in Solid mode seems to work pretty well but it doesn't use the lights you've created, it's just a virtual light, anyway Solid mode is only made to work on modelling, not to work on material or prepare a render $\endgroup$
    – moonboots
    Apr 7 at 11:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .