6
$\begingroup$

So, I have a problem using the Volumetric shaders in cycles. When I am viewing them in the viewport, they seem to be coming out perfectly fine, whereas when I render them, only the glass surface is visible and no light scattering/absorption occurs.

The Preview in the Viewport
Preview

The Rendered Image
Render

(Sorry I have used a very low resolution, but the difference hopefully is clear)

[Edit] You can find my blend file here.

$\endgroup$
  • $\begingroup$ Oh yeah, I'm using Blender 2.74 if that's of any help. $\endgroup$ – Karan Ganju May 28 '15 at 1:29
  • $\begingroup$ Could you upload the .blend file to a service like Blend-Exchange $\endgroup$ – VRM May 28 '15 at 2:59
  • $\begingroup$ Cycles allows for a lot of ways to adjust raytracing, and I'd imagine it'd be possible to have some aspects of raytracing enabled in preview but disabled in final render. Check the render settings for any obvious differences between preview and render settings, then if that doesn't work try playing with other relevant-looking settings in case there's some bug that allows a setting to affect one render mode but not the other. $\endgroup$ – Xazo -Tak May 28 '15 at 3:51
  • 1
    $\begingroup$ Sorry, was in a hurry in the morning and didn't know how and where to upload the blend file. Thanks. I've updated the question. $\endgroup$ – Karan Ganju May 28 '15 at 11:46
1
$\begingroup$

You have a Solidify Modifier on your pawn(s) of -0.011 thickness that is set to take effect in the render, but not in the viewport. This is causing your pawns to be hollow inside during the final render, but not when seen in the viewport. This is also why your Material Preview looks much denser and darker than your final render. Since when rendered the material is paper-thin, there is not enough geometry for the volumetric properties to show. I think you either didn't mean to be using that modifier, or didn't mean to make it that thin.

General good advice:

  1. always look at the Material Preview to see what Blender "thinks" your material is supposed to look like in its raw state.
  2. Always consider what's happening in your Modifier stack.

Happy blending.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.