1
$\begingroup$

I noticed during baking physics (with 2,500 rigid bodies in a solidified cylinder) that, instead of using all 8 cores on my AMD FX-8150 CPU, it maxes one out at 100%, but then passes the baton onto another one, which goes at 100%, etc. but never seems to use them synchronously.

system performance graph

Baking takes a while with that many rigid bodies; is there a way to configure Blender to use all 100% of CPU when baking physics?

(Running Blender 2.74 x64 on Ubuntu GNOME 15.04 x64)

$\endgroup$
  • 1
    $\begingroup$ I guess rigid body baking just isn't multithreaded. Also cycles doesn't handle physics simulations, it only does the rendering. $\endgroup$ – gandalf3 May 27 '15 at 23:15
  • $\begingroup$ @gandalf3, if so, is there any way to... I dunno... enable multithreading? $\endgroup$ – Jesse May 27 '15 at 23:57
  • 1
    $\begingroup$ @TravLR See this question: blender.stackexchange.com/questions/27125/… $\endgroup$ – Ray Mairlot May 28 '15 at 0:46
  • $\begingroup$ @TravLR Not unless you count writing it yourself in C ;) It's a feature which just doesn't exist (yet). $\endgroup$ – gandalf3 May 28 '15 at 9:42
  • $\begingroup$ @gandalf3, heh fair enough. :) Well, if/when it becomes a part of future Blender iterations, it'll be a huge benefit. $\endgroup$ – Jesse May 28 '15 at 20:02
0
$\begingroup$

It looks like this is a known limitation of Blender (both the past 2.74 version and the current 2.76, at this time). The Cycles engine just doesn't (yet) have multithreading capability for baking rigid body physics. (Possibly soft body physics, also, though I haven't tested.)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.