0
$\begingroup$

Was following the Blender Guru's donut tutorial (10th part). As I was trying to light the scene without any lamps and using the sky texture, first the scene didn't go completely dark and when I added the sky texture it didn't show up in the scene either.

Tried to make the scene dark thought that might help with the sky texture but that didn't work out either, though the sky texture renders out properly just doesn't show up in the scene.

Here's the blender file. Any help would be appreciated. https://drive.google.com/file/d/1FH2txCY1TcSH_Q0qNbqp1U2r9BnErvAC/view?usp=drive_link

$\endgroup$
3
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ Commented Mar 26 at 11:41
  • $\begingroup$ Light your scene without lamps? In Cycles use only Sky Teksture on the world. The world in itself emits light. $\endgroup$ Commented Mar 27 at 10:15
  • $\begingroup$ @Lukasz-40sth According to the question the scene already used the Sky Texture and the issue which is asked for here is why it does not work. If you would have read my answer you would see that there seems to be a great misunderstanding of how the world setup works and what the Sky Texure is. So just saying "use the sky texture" without further explanation to someone who thinks he already uses it will not help much. $\endgroup$ Commented Mar 29 at 9:04

1 Answer 1

0
$\begingroup$

First of all, it does not render out properly. If you really render it by hitting F12, everything is completely black.

What seems to work properly for you is the render preview in the viewport. Usually this would be black as well, but you have disabled Scene World in the Viewport Shading options. Which means, it uses the built-in HDRI from the Material Preview to light the scene - but this will not be rendered in the real render.

scene world disabled

The other problem is, even when you enable the Scene World, it would still be black because you have deleted the World from the scene. That's why there is no world to choose from in the list and the button says New.

no world

Next is, you are not using the Sky Texture. You set values for Blender's Sun Position tool which can be used to set the angle etc. of a sun lamp to some real calendar data. But this only works if you 1) have a world in your scene and 2) if you have chosen a Sun lamp object which should be using this data which you have not, because there is no sun object in your scene.

world and sun required

So to get real lighting in your scene do the following: to have a world lighting that will actually be rendered you need to enable Scene World again in the Viewport Shading for the Render Preview.

enable scene world

Then go to the World Properties tab and click on the New button.

new world

Now it depends on how you want to light your scene. You are talking about the Sky Texture. If that is what you originally wanted to do, go to the Surface settings of your new world, click on the yellow circle button next to Color and choose Sky Texture from the menu. Now you can tweak the settings to your liking.

sky texture

Or you want to use the Sun Position settings. In this case the first thing you have to do is add a sun lamp in the viewport: Shift+A > Add > Light > Sun. Then choose this as Sun Object in the Sun Position settings.

sun position settings

What remains is choosing the Usage Mode. The default is Normal, this way you can choose a date and time etc. and the Sun Object's rotation will be adjusted to that. The rest of the sky will be color and strength you have set for the world.

The other Usage Mode is Sun + HDRI texture. In this mode you cannot choose date/time and it requires you to select an Environment Texture for the world (as Color where you picked the Sky Texture in the other lighting method). With this mode you can pick the sun's position where it is located in the HDRI texture.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .