3
$\begingroup$

I have a problem with very obvious banding showing up when using a TIFF generated from an Digital Elevation Model in ArcGIS. The image you see uses an exported 24 bit TIFF. I think it could be solved if I can use an exported 32 bit grayscale TIFF from ArcGIS, but this won't load in Blender. I can also export the height data as an ASCII file, but see no way of using this, except by maybe writing a Python script.

Banding in the terrain

I've read something about Blender being able to use OpenEXR, but I can't figure out how to convert my TIFF to this format. I'm on a Windows 7 machine. Can anyone help me, or know a way to solve this without converting to EXR?

$\endgroup$
  • $\begingroup$ You say the above image doesn't load in blender, what error are you getting? What options do you have when exporting? $\endgroup$ – sambler Oct 4 '13 at 11:15
  • $\begingroup$ The image you see above is with a displacement map that does load, however due to it being low bit depth you get the obvious banding on the plateau at the top. When I try to use a 32bit TIFF it doesn't load correctly. I get no errors, but no displacement either. I can export a number of different formats, but TIFF is the only one supporting 32bit. $\endgroup$ – cybrbeast Oct 4 '13 at 11:37
1
$\begingroup$

You can convert a .tiff file to a .exr file using blender.


First switch to the Node editor

Switch to the node editor


Next in the bottom panel you will see a box with 3 buttons in it click on the right one. Also enable 'use nodes' and 'backdrop'.enable backdrop and use nodes, also switch to compositing setup


Next add an input. 'Shift + A' Input > Image. Navigate to your image you would like to convert.Add image input


Next add an output. 'Shift + A' Output > Composite. enter image description here


You now should have something like this.enter image description here


Thats all the nodes you need. Next you will need to change the render settings. Render settings You will need to change the render size to the size of your image. You can get this by in you file browser RMB on the file properties > details. Change the output type to EXR (not multi-layer) and make sure that its set to 'float full' not 'float (half)' full is 32-bit half is 16-bit. Make you sure you know where you are saving the image.


Next hit render and wait for it to render. Should be pretty fast though.final render output



If that does not work you can you use irfanview to export the tiff into a different file format. Here is how. First open irfanview.


Then open your file you want to convert.


Choose 'File' > 'Save As'

File > Save As


Chose where you want to save it and the format.

Save as tiff

| improve this answer | |
$\endgroup$
  • $\begingroup$ added the detailed instructions $\endgroup$ – user320 Oct 3 '13 at 21:23
  • $\begingroup$ Thanks for the detailed instructions. However it's not working for me, it just loads as black. See the screenshot, it includes two Irfanview windows with the same file open, one showing the image, the other the image properties. i.imgur.com/LXikk9m.png $\endgroup$ – cybrbeast Oct 4 '13 at 8:14
  • $\begingroup$ Photoshop also has trouble displaying the image, it's just black and white, but it does show detail if I turn the exposure way down in the adjustments, see screenshot. The black white divide seems to be where the DEM has negative values in ArcGIS. Maybe that has something to do with it? i.imgur.com/0qJVp0y.png $\endgroup$ – cybrbeast Oct 4 '13 at 8:19
  • $\begingroup$ can you upload the image so i can take a look at it? $\endgroup$ – user320 Oct 4 '13 at 11:08
  • $\begingroup$ As it's protected data and a rather large file I'm sending you a cropped export: mega.co.nz/… $\endgroup$ – cybrbeast Oct 4 '13 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.