0
$\begingroup$

I'm trying to bake the sun's lighting to a combined texture. It looks great on viewport shading, however I get an over-saturated result when baking to texture. I'm using a Principled BSDF material with diffuse, normal, roughness, metalness maps which were exported from substance painter using the "Blender" preset.Textures are set on sRGB(diffuse) and non color (rest). Everything is on default settings except "color management" settings (see bellow) Why do i get this problem?Is it because of color spaceAny ideas?

Viewport Baked Texture

Settings

$\endgroup$

1 Answer 1

0
$\begingroup$

Neither exposure nor view transform get baked into textures. These are intended to be used after the texture is read-- they are "post-processes." Because you have overbright output on your surface, compensated for with exposure and view transform, you get an clamped, overbright bake.

If you want to bake a simple plane and you want to include rendering settings like exposure and view transform (and some others, gamma, color curves, anything you ever do in the compositor) then you can create an orthographic camera, pointing at the plane, with appropriate ortho scale and rendering resolution, and just render rather than bake.

If you don't have a simple plane, you can still build many post-processes into your render, but you need an extra step. First, you can bake a combined bake into a non-color, floating point texture, saved as an .exr; then, you can emit this texture from a plane and render from an orthographic camera as above.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .