0
$\begingroup$

After I generate the bones using Rigify pitchipoy none of the rotation commands work.

Rig before generating

controls like the highlighted one wont work.

Ik controls do seem to be working though I can not rotate the wrist to match the position.

Rig before generating Controls like the highlighted one wont rotate The IK controls of the hands and feet do seem to work, but I cant move the wrist to match the rest of it.

I tried to show you everything you need to see in the pictures I'm not sure what else you might need to see. Please let me know. Thank you for your time :D!

EDIT!!! I found a new bit of weird. I turned on "Auto IK" which fixed some of the issues but the arms are still funky enter image description here

$\endgroup$
1
$\begingroup$

enter image description here

It is possible that for some reason or another, when you generated controls, a limit rotation constraint was placed on the bones. If this is the case, when you go to pose mode, select a bone that won't rotate, and look at the bone constraints panel, you might see something like this.

|improve this answer|||||
$\endgroup$
  • 1
    $\begingroup$ I didn't find anything like that $\endgroup$ – Matt A. Draft May 25 '15 at 3:59
  • 1
    $\begingroup$ I turned on "Auto IK" that fixed the waiste but not the wrist. I've also added an image to show what happens when I rotate the arms now. $\endgroup$ – Matt A. Draft May 25 '15 at 4:09
1
$\begingroup$

In pose mode, select a bone you want to rotate, check your transform tab (N key), is the rotation locked?

enter image description here

|improve this answer|||||
$\endgroup$
1
$\begingroup$

It looks like you have all the layers enabled here which is not quite as desired.

Hide all the layers. After that, use the buttons to enable Arm IK Left and Arm IK Right. Make sure the IK / FK slider is set to IK. If you are not sure which is which, try both. Maybe that will solve your problem. The slider is located in your viewport in screenshot #1 and #2 on the right panel.

Ensure Auto-IK is disabled

On the bone properties panel, ensure the rotation on XYZW is not "Locked".

I feel like the IK / FK slider is your issue. It's the reason why your mesh does not deform when you move the IK part of the Armature. It could also be the cause for it's inability to rotate.

|improve this answer|||||
$\endgroup$
1
$\begingroup$

I looked at your screenshots, you have "manipulate center points" turned on. It would cause the problems you described. See Screenshot.
manipulate center points button

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Please do not write in the images. A simple mark around the button would be sufficient. $\endgroup$ – David Jun 8 '15 at 22:22
  • $\begingroup$ No problem. I edited the post. $\endgroup$ – DavidMcDermott Jun 8 '15 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.