2
$\begingroup$

I want to outline the edges of the following chip object using a grease pencil line art modifier. However, it only outlines some of the edges: only the ones forming the silhouette of the object. The other edges are missed, even though their angles (90° and 135°) are well within the set threshold. I added a cube to show that similar edges are outlined there. Any idea what could be going wrong?

missing lines

Here's the .blend file, in case that helps.

$\endgroup$
2
  • $\begingroup$ For some reason, your chip object isn't affected by Line Art modifier > Edge Types > Crease Threshold. I'm unable to find why. Any idea what operation/modification you may have done on the chip object ? $\endgroup$
    – Lutzi
    Commented Mar 7 at 12:23
  • $\begingroup$ @Lutzi I created it by importing the shape from a .dxf file, converting that to a mesh and then extruding. Maybe that has something to do with it? I would have thought that the final mesh should be identical to one created by other means.. $\endgroup$
    – schtandard
    Commented Mar 7 at 13:35

1 Answer 1

2
$\begingroup$

Correct normals

Some of your normals are pointing inwards. First select your chip object, go to Edit Mode, A to select all, Alt+N > Recalculate outside.

Disable auto-smooth

Still with the chip object selected, disable Auto-smooth

Disabling auto-smooth

Tweak grease pencil

Select your grease pencil object. Then you can tweak the Crease Threshold. If you go all the way to 180°, you'll see one of your face isn't flat. You could just set it to 179°, or rework your geometry to have flat faces.

Tweaking crease threshold

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .