4
$\begingroup$

I have just added image sequence as texture and when i play the timeline the texture goes to next frame automatically why ?

here are the source blend + image files please check

Video of the error

enter image description here

$\endgroup$
2
  • $\begingroup$ By default if you load an image sequence it will play at the same frame rate of your scene's frame rate. To control what frame appears on your texture you'd need to animate the offset/start frame/frames values on the texture nodes. $\endgroup$ – user1853 May 24 '15 at 16:48
  • $\begingroup$ Related: How can I make a “Movie Clip” node start at a certain frame of the scene? $\endgroup$ – user1853 Dec 29 '17 at 2:27
6
$\begingroup$

You need to animate the 'offset' value of the image node. The offest needs to decrease by one for every one frame you go forward.

So on frame 5, you would need to make the offset '-4' as you have gone forward 4 frames (from frame 1):

enter image description here

So even though you have gone forward it will still show frame 1 of the image sequence.

If it was frame 7 you would offset by '-6' frames to still only show frame 1:

enter image description here


The following only works for the viewport, not the render.

You have 'Auto Refresh' turned on on your image nodes:

enter image description here

Turn this off if you don't want the frames to update automatically on frame changes.

$\endgroup$
8
  • $\begingroup$ it just stops changing in viewport preview. But when i render movie (render animation) the frames are still chaninging. If i uncheck Cyclic then it gets pink once the last frame in sequence is changed. But all this without i animation it !! $\endgroup$ – ashwin May 25 '15 at 9:30
  • $\begingroup$ Then it seems @cegaton's comment was correct about needing to animate the offset. Cyclic is if you want the image sequence to repeat. If you turn it off and you exceed the image sequence frame range it will display pink as it regards the textures as 'missing'. $\endgroup$ – Ray Mairlot May 25 '15 at 9:32
  • $\begingroup$ i understand why it gets pink but why it is changing automatically. And its even not even working if i key the offset. $\endgroup$ – ashwin May 25 '15 at 9:34
  • $\begingroup$ Because you have set it to image sequence. It is presumed you want to change to the next image as that will be the most common useage. $\endgroup$ – Ray Mairlot May 25 '15 at 9:36
  • $\begingroup$ youtu.be/u-H0xmViiFQ please see the video its animating even when the offset is keyed to zero $\endgroup$ – ashwin May 25 '15 at 10:08
2
$\begingroup$

If you don't want Blender to automatically advance the visible frame of your image sequence, set the "Frames" parameter to 1. This will effectively lock the image sequence on its currently visible frame, defined as: "Start Frame" + "Offset."

With this setup you should be able to animate the "Offset" parameter (or drive it with a driver) independent of the current frame.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.