0
$\begingroup$

this is probably a really simple solution I'm missing, but the keyboard shortcut for Rotate (R) has stopped working properly for me. I press R in Object Mode and it immediately jumps to the Toolbar Shortcut for Rotate instead of staying on the Select Box. It only allows me to rotate using the handles, I can't use the keyboard shortcuts for rotating on the X, Z, or Y Axes anymore, or type the degrees I want it to turn.
Grab and Scale are fine though and still work normally. Also, the Rotate keyboard shortcuts still work in Edit mode, just not Object Mode.
One other thing; It's not an issue with the Tool > Transform > Affect Only (Origins, Locations, and Parents boxes are all unselected) I'm using Blender 3.6 on Windows 10 and it's been working fine for the past few months (also tried using an old copy of Blender 3.4 I had installed and the keyboard shortcut worked fine with it) but today it only started doing this.
I know this is probably something really basic I've toggled on or disabled by mistake, but I've tried looking for a solution online and so far I can't find anything, so any help would be appreciated

enter image description here.

$\endgroup$

1 Answer 1

1
$\begingroup$

That setting is usually controlled by changing Preferences > Keymap > Tool Keys from the default Immediate to Active Tool. However I'd normally expect that to apply to all hotkeys.

enter image description here

Try toggling between those settings and then use Save Preferences from the bottom-left dropdown in each state to see if that kicks it back into life.

enter image description here

$\endgroup$
2
  • $\begingroup$ Yes! That did the trick! I don't understand how that worked but thank you for that! $\endgroup$ Mar 2 at 23:04
  • $\begingroup$ I have to admit I don't know why it was just the R shortcut key that wasn't working correctly, but glad it solved the problem! Please mark my answer as accepted (green tick). Thanks. $\endgroup$
    – John Eason
    Mar 3 at 0:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .