1
$\begingroup$

I have an image sequence which has building lights only, everything else is totally black. I'd like to render just the light and no black. Is there a way to do this?

$\endgroup$
1
  • $\begingroup$ Hello and welcome. As it stands this question is unanswerable and was put on hold for lack of essential details to understand the issue. Risking stating the obvious, only you have access to your scene, so unless you describe it thoroughly you alone know your exact setup, settings and what steps you took to arrive where your are now. Describe the issue in detail, add reference images of what you want to achieve with the edit button above. Don't post comments or ask a new question, editing will automatically queue it for reopening review. $\endgroup$ Feb 28 at 10:30

1 Answer 1

0
$\begingroup$

You can enable emission in the render passes. Then, in the compositor, you need to plug the emission slot into the render output.
Render Layers node
Emission will appear next to the Image output.

Also, to avoid black everywhere else, check Transparent Background under "Film" in the render settings.

$\endgroup$
4
  • $\begingroup$ Have you tested your answer? Your Render Layers does not even show the Emit pass... A transparent background will not make the Emit pass in the Compositor transparent where there is no emission, it will still be black. Also the Alpha will be white everywhere where objects are, not only the emissive parts. $\endgroup$ Feb 28 at 9:36
  • $\begingroup$ @GordonBrinkmann Whoops, you're right, I was trying to do it from memory. Should I delete my answer? $\endgroup$ Feb 28 at 21:30
  • 1
    $\begingroup$ Many thanks, that's perfect! $\endgroup$
    – Luponian
    Feb 29 at 12:19
  • $\begingroup$ Well, I'm glad it worked out! $\endgroup$ Feb 29 at 15:28

Not the answer you're looking for? Browse other questions tagged .