2
$\begingroup$

I'm making a bread tower and I'm using emission planes for the light. For some reason only on the second row some of the planes don't show up in the render but do in the viewport:

viewport: enter image description here

render: enter image description here

The viewport lights look much more dense than the render could somebody explain why this is happening and how I'd fix it?

$\endgroup$
2

1 Answer 1

4
$\begingroup$

That's just simple Z fighting, because each floor of your building has a top and a bottom face which lie in the exact same location when you set the Relative Offset to 1 in the Array modifier. So it's not the light panels that are not showing up, it's the Z fighting that makes the ceiling pitch black so it cannot reflect the light.

Three possible solutions:

  1. Enable Merge in the modifier

  2. Set the Relative Offset > Z to 1.001 instead of 1.000 to leave a little gap (even 1.0001 should be sufficient)

  3. Delete one of the faces, either top or bottom (but of course one side would be open then, so I would rather do 1. or 2.).

enter image description here

By the way, you know that some of those lighting panels are poking out of the front of the building?

faces poking out

$\endgroup$
1
  • $\begingroup$ Thank you so much $\endgroup$
    – CowToesies
    Commented Feb 26 at 18:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .