5
$\begingroup$

Whenever I do an animation the graph editor gives me curves.

Curves

But im not getting any curves.

no-curves

$\endgroup$
  • $\begingroup$ Is it possible that the changes are so small that thy don't quite show on the graph? Try scaling the graph view on the Y axis. $\endgroup$ – cegaton May 21 '15 at 22:52
  • $\begingroup$ When i clicked on the normalize it gave me the curves thanks. $\endgroup$ – BoxOfficePosion May 21 '15 at 22:58
  • $\begingroup$ You have to click the normalize button and scale it out with CTRL + Middle mouse button. $\endgroup$ – BoxOfficePosion May 21 '15 at 23:00
5
$\begingroup$

Some curves may not be visible due to their high value, or too low value.

First of, check if you see all curves by adjusting vertical zoom, with CTRL + MMB MMB, then drag up / down.

Also, you can check the Normalize button at the bottom toolbar of the graph editor, and all curves will be clamped between -1 and 1 so you can see them all in a more condensed area of the graph.

$\endgroup$
4
$\begingroup$

Pressing Home will zoom the view to make all keyframes visible. For smaller/laptop keyboards without a home key this can also be found in View->View All

You can use the scroll wheel to zoom the graph editor in/out or use ⎈ Ctrl MMB MMB and drag up/down to zoom the values or left/right to zoom frames.

It is most often the rotation values that are large, one way to keep them in range with other keyframes is to work with radians instead of degrees or to use Quaternion rotations.

Radians can be enabled in the scene properties under units. This option allows you to change between degrees and radians as you want.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.