2
$\begingroup$

everyone! I need assistance with Rigid Body simulation in Blender. I have objects that I want to activate one by one. I've set "Start Deactivated" for all of them and adjusted the activation keyframes to different time intervals.

I even baked the rigid body simulation to ensure correctness, but regardless of the settings, deactivation occurs at a unified moment. Is there a way to shift each simulation independently?

(The option of baking the animation doesn't quite fit my needs, as the number of objects is much larger than in the test scene in the video.)

https://youtu.be/WIahXtIKLHo - example

Thanks in advance for your help!

$\endgroup$
2
  • $\begingroup$ Probably related not the topic but addon "Copy particles to Rigid Body" blender.stackexchange.com/a/251696/2214 $\endgroup$
    – vklidu
    Commented Feb 24 at 21:50
  • 1
    $\begingroup$ are u sure that you keyframed deactivated on and off? i tried it and it worked. Since you didn't show us, pls provide blend file and tell us your blender version. thx $\endgroup$
    – Chris
    Commented Feb 25 at 7:45

2 Answers 2

1
$\begingroup$

Make sure, you keyframe "deactivated" on, and one frame later, "deactivated" off. I tried - it works.

enter image description here

Note: what doesn't seem to work is: if you copy an already animated rigid body with keyframes, and just move the keyframes in the timeline - it won't work. I had to delete the keyframes of the new object, and insert them manually. Then it worked.

$\endgroup$
0
$\begingroup$

You can either make the action a single action for each object then move the keyframes:

enter image description here

Or push down the actions in the Dope Sheet window in Action Editor mode...

enter image description here

...and offset each strip in the Nonlinear Animation window:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .