5
$\begingroup$

A png image to be used for background.

A video sequence of numbered png files ( which were rendered in Blender with alpha.) is to be the foreground.

Selected backgound png, then video sequence, add effect strip alpha over. No background visible. (Tried every combination I could think of. If use alpha over the background is the only image visible. Use alpha under the foreground is only image visible. display is sRGB)

Tried with single .png file as forground. Same results.

I am wondering if the video sequenced pngs have lost the alpha channel. On the video display there is no checkerboard as there was within the 3d scene for the background. (The black part of the video looks solid black on the display rather than checkerboard)

$\endgroup$
  • $\begingroup$ I looked. No didn't use RGBA used RGB. $\endgroup$ – The Beachdancer May 22 '15 at 16:29
  • $\begingroup$ I looked. No didn't use RGBA I used RGB. There always seems to be another setting that a user has to know about, but which is 'secret' within Blender. Shame because I had set the display to show the background as transparent and it displays as such in 3D render mode. I assumed that that was all I needed to do. Thank you for explaining. So, is there a way to turn the solid black in the png into transparent? $\endgroup$ – The Beachdancer May 22 '15 at 16:39
4
$\begingroup$

Your PNGs were probably not exported with the alpha channel.

Make sure you export the PNGs as RGBA

enter image description here

To check if your image has an alpha channel load it in the UV/Image editor.

An image with alpha channel will look like this, with a checker pattern on the alpha:

enter image description here

An image with no alpha channel will not show that pattern, but a solid color:

enter image description here

To make the alpha channel transparent on the VSE, select the strip with the pngs, presss N to make the panel visible, and in the blend type select alpha over. enter image description here

$\endgroup$
  • $\begingroup$ I did not even know there was an Alpha Over effect strip. I always use the Blend (blend_type) = Alpha Over like you point out in the last image. $\endgroup$ – Mutant Bob May 21 '15 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.