1
$\begingroup$

I'm tried rendering cubic skybox with a procedural Sky Texture in Blender via Cycles and unexpectedly encountered artifacts at boundaries of rendered square images (which a skybox is then assembled in bitmap editor). Each square image has a noticeable artifacts at border, especially in darker areas of the image (as screen seen).

enter image description here

You can reproduce this problem in Blender in 3 minutes:

  1. Create general empty scene (delete cube and light)
  2. Set up World Shading nodes with Sky texture as screen seen.
  3. Place Camera at zero position (0,0,0) and angles (90, 0, 90).
  4. Set Camera properties Lens unit to Field of View, FOV = 90 degrees.
  5. Set Output format properties resolution 512x512 pixels (or 1024x1024 - any square image for cubic skybox).
  6. Render Image #1, save on disk.
  7. Rotate Camera to angles (90, 0, 0).
  8. Render Image #2, save on disk.
  9. Open any bitmap editor (Photoshop, Gimp etc) and make common wide picture from square Images #1 and #2 (place them side to side).
  10. Check border between Image #1 and #2.
  11. In my case always seen artifacts (1-2 pixels width dark distortion edges) at boundaries each square image as screen seen.

Can anyone check this problem and tell how to fix in the Cycles rendering settings to remove such artifacts at borders of square images?

$\endgroup$

2 Answers 2

1
$\begingroup$

You can use a cube, smooth shaded, with the following shader, and bake it:

enter image description here

Using "normal" instead of "reflection" should work the same, I think. Same thing if you subdivide the cube to make it spherical.

But that does not seems to matter as normals are smoothed.

$\endgroup$
2
  • $\begingroup$ Sorry @lemon, when I returned to creating skyboxes I discovered that your variant of baking skybox still had problem with artifacts on the edges of baked cubemap images. Please see my answer. $\endgroup$
    – Nazar
    Mar 21 at 12:58
  • $\begingroup$ no problem, it is normal Nazar $\endgroup$
    – lemon
    Mar 21 at 13:03
0
$\begingroup$

When I returned to creating skyboxes I discovered that @lemon variant of baking skybox still had problem with artifacts on the edges of baked cubemap images.

The artifacts are same: dark distortion edges at boundaries between the render and the empty area of the image (as screen seen).

But at least I found one solution (far from optimal, unfortunately):

If you uncheck Denoise option, artifacts around the edges of the baked cubemap won't appear. I've tried different params of Blender's built-in denoisers, but they all add such artifacts. Perhaps there is another way, because then for a clean cubemap of real complex skybox scene you will need much more baking time with a significant amount of "Max Samples" for Cycles render when Denoise OFF.

I don't want to mark my answer as correct because instead of a few minutes I have to wait whole hours of baking with a much worse cubemap quality (lots of pixelated noise without the denoiser). I also believe that the denoiser should not degrade the cubemap with edge artifacts.

So, is there another better way? enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .