0
$\begingroup$

I have a mesh to which I would like to add a bevel modifier and shade it auto smooth but when I increase number of segments, shading issues are starting to occur.

This mesh is a mirrored half of the cube with some booleans and extruded regions which i cut out with a knife. It has quite a lot of edges that run through entire mesh which, for some reason, I can't dissolve and I think they might be a problem (or one of many).

When I set only 1 segment in bevel, it seems to be perfectly fine.

How can I fix that so it works fine with any number of segments?

Here are some screenshots that maybe will help:

$\endgroup$
1
  • 1
    $\begingroup$ Without a bevel, your angles are being made sharp by your autosmooth settings, because the angles are all 90 degrees. These sharp edges make all of your normals flat-- all of the corner normals for a given n-gon are the same. After the bevel, the angles between any two faces on your old edges is less than the autosmooth angle, and so now the edges aren't being sharpened, and normals are being interpolated along whatever lines get created by Blender's triangulation, And since you're using ngons and booleans, those lines aren't predictable or what you want. $\endgroup$
    – Nathan
    Commented Feb 18 at 2:48

0

You must log in to answer this question.

Browse other questions tagged .