1
$\begingroup$

Material Preview displays just fine when in Object Mode, but in Edit Mode it's as if the Viewport Shading is set to Solid instead: the faces of the mesh show as grey instead of the material. How can I preserve Material Preview while in Edit Mode, so that I can see how changes to the mesh affect the material in real time in Blender 4.0?

Here it is in Object Mode, with a simple white material and smooth shading:

object mode

And here it is in Edit Mode:

edit mode

I could split open a second viewport, but that takes a lot of screen real estate.

$\endgroup$
3
  • 1
    $\begingroup$ Hello, in Material preview mode you should be able to see the material in both Object and Edit mode, but maybe show a screenshot? $\endgroup$
    – moonboots
    Feb 15 at 17:48
  • $\begingroup$ @moonboots Sure thing, I've added screenshots now. $\endgroup$ Feb 15 at 21:45
  • $\begingroup$ OK that's weird, it should not work like that... $\endgroup$
    – moonboots
    Feb 16 at 8:13

1 Answer 1

2
$\begingroup$

I figured it out; I had Mesh Analysis enabled in the Mesh Edit Mode Overlays without realizing it. This covers the faces of the edited mesh with an opaque overlay, the color of which indicates distortion.

If you forgot that this was enabled like I did, you can disable it here: enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .