3
$\begingroup$

I made a simple character in blender game engine. He's parented to an armature, so he can walk, ext. Now I want to make him a character, so he can jump, can't go through obstacles, have a step height. I think you do that by setting the armature to Physics type: character. And it kind of works. But the collision bounds are a box, so the character sinks into the ground.

here's a picture enter image description here

The white box in the middle of a character is his bouning box. How can I fix that? I tried the collision bounds, but it doesn't work. No matter which one I chose, it had no effect whatsoever.

Please help. Thanks!

$\endgroup$
  • $\begingroup$ check the box that says "collision bounds" $\endgroup$ – Scalia May 20 '15 at 16:03
  • $\begingroup$ you would never really put physics on the armature, make a collision box for him. $\endgroup$ – Scalia May 20 '15 at 16:04
  • $\begingroup$ checking 'collision bounds' doesn't work, even though it displays it. $\endgroup$ – Roki Podpecan May 20 '15 at 18:11
  • $\begingroup$ what do you mean by 'make a collision box for him'? $\endgroup$ – Roki Podpecan May 20 '15 at 18:12
  • 1
    $\begingroup$ make an actual box ie cube, scale it to the collision size you want. Make it a collision object, and parent the armature to the box (ie the box is the armature's parent so it follows the box's physics). Also make it non-renderable. $\endgroup$ – beiller May 20 '15 at 18:37
0
$\begingroup$

Don't apply the physic to your character's Armature directly as Armatures aren't recognized as an Actual model object but only an unrendered object that makes your character's body part move (rig), If you want to make your character collide with other thing, try this:

  • Make sure that your char's armature and it's model have No Collision physic assigned.
  • Then, make a Cube and resize it to match with your Armature/Character's size and Place it around your character, You can rename the Cube as "charbound" if you want.
  • Set the Cube's physic to Dynamic and then Set the Cube as parent of your Armature (not the entire character).
  • Move the basic movement control in Logic Bricks from your char's Armature to the Cube, but don't move the Action or other Actuator more than Motion Actuator.
  • And at last, make the Cube Invisible (physic tab > enable Invisible button) and Box Collision Bound.

If you want to make him "jump", try using Servo Control Motion Actuator in Game Logic. by adding Z-axis Linear Velocity, Enabled Z-axis Movement and Adjust Z-axis Max/Min speed value then it would jump, make sure you activate the Collision Bounds on Physic Tab.
Alternatively, you can use Character Motion Actuator and Enable "Jump" toggle there (Actually, I've never tried it. But I'm sure it can).

$\endgroup$
  • $\begingroup$ I moved to unreal engine 4 since i posted this question so it's no longer relevant for me, but thank you nonetheless. Maybe someone else will find it helpful. $\endgroup$ – Roki Podpecan May 7 '17 at 9:42
  • $\begingroup$ Ahaha, I know someone my end up on giving up option other than continuing works with blender game engine. Anyway, may your game became the best game. $\endgroup$ – SyahrielIbnu_x86 May 7 '17 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.