0
$\begingroup$

SOLVED: see scurest's and Pedro Ribeiro's answer. Thank you everyone for helping out.

External Data --> Find Missing Files doesn't work for me. Restarting Blender also doesn't work. enter image description here

enter image description here

enter image description here

I am unable to post the .blend file due to size (over 150MB from texture and nodes) so I will have to post the node tree.

enter image description here

This will make the page very cluttered but hopefully it is necessary.

enter image description here

The Principled BSDF for the Plastic works fine though I didn't show it. And Blender doesn't report any missing files.

Showing the process of checking all the Node Groups will make the page more cluttered. But I can assure that there are no missing files.

The low quality is due to the 2MB limitation. There's nothing else I can do.

Should mention that it also doesn't work with anything else than the Plastic textures. Solid colors and anything else not image-related works fine.

enter image description here

Mix Factor from 0 to 1.

$\endgroup$
6
  • $\begingroup$ Hello there are some node groups in your setup, there may be some Image Texture nodes in those? $\endgroup$
    – moonboots
    Commented Feb 13 at 19:46
  • $\begingroup$ Yes, there are Image Textures but none of the files are missing. $\endgroup$ Commented Feb 13 at 19:47
  • $\begingroup$ Pink means missing texture files, so I believe you have missing texture files. You don't show what's in the node groups, and it's very small compressed screenshot where it's not even possible to see what you do show. If mix node has factor of 0 or 1 it will display 1 or 2 input fully, so it makes sense if one of the inputs connected is missing it might behave this way only when you connect specific thing into factor. So I would recommend forgetting the assumptions you have now and rechecking everything. $\endgroup$ Commented Feb 13 at 20:48
  • $\begingroup$ @MartynasŽiemys I have added more information. Please check it out. TLDR: Blender reports no missing files. The Node Groups files are also not missing. Mix Factor from 0 to 1 works fine without the Noise Texture. $\endgroup$ Commented Feb 13 at 22:14
  • 3
    $\begingroup$ Perhaps you've hit the texture limit. Note that Color Ramps count as textures too. $\endgroup$
    – scurest
    Commented Feb 13 at 22:34

1 Answer 1

2
$\begingroup$

Since you say you have like 150MB of textures and nodes, the problem could be that your material is too complex or has too many attributes and the GPU is overloading.

I made a question recently about attribute limits on the shader editor and basically there seems to be a limit of 14 readable atributes at the same time across the total of materials in an object, (one stops working if 15, for example), and if you go past 16, the shader breaks or, at least, stops receiveing the textures correcty, so it cannot display them and it turns pink (without them actually be missing from the project).

Attributes on your shader could be things like simply the outputs from "Attribute" nodes (example: if you're passing values from Geometry Nodes to the Shader Editor with Store Named Attribute nodes; on my Question I explain a trick to increase this by 4x max btw), but I noticed it is as well stuff like the output from Texture Coordinates nodes (with "Generated" outputting 2 attributes, and the rest 1), and image or procedural textures also seem to use some attributes.

When you connect that Mix Shader you're joining the attributes from both sides and it basically adds up to more than 16 (but some already stop working at +14, like I said, it just doesn't turn pink).

When you swapped one of the sides for a simple Principled Shader you removed all attributes coming from that side, that's why it worked again.

Unfortunately there's not much you could do, as this attributes limitation if built-in into EEVEE. The best solution I can give you is try making the same material but with less different textures (images, noises). Try re-using them - one feeding many - specially for similar noise types.

Note that even when you're using textures without connecting a Texture Coordinates node, it still gets the attribute from a "ghost" one - image textures default at UV, and procedural textures at Generated (which, keep in mind, use 2 attributes). So if you have a procedural texture without a Texture Coordinates node and you don't care about using "Generated" even once on your material, connect a coordinates node and change it to Object to spare 2 attribute slots.

$\endgroup$
1
  • 1
    $\begingroup$ Thanks, Pedro Ribeiro! Your answer works. I guess that makes both you and scurest correct. $\endgroup$ Commented Feb 14 at 0:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .