-1
$\begingroup$

I have imported an obj file into Blender and made a rounded plane as a background. I made the background blue. After that I have inserted some light and raised and ripped in the settings, but without being able to see the light.

There are also no shadows on my objects. I've seen countless tutorials without it helping. Do any of you have an idea what I have done wrong. Is there a tick I need to put somewhere to show light, or can I have done something else that eliminates the possibility of shadows/lights.enter image description here

$\endgroup$
4
  • $\begingroup$ I guess we need more information on your scene settings. How far is your light from the objects or the floor? The Power of 20000 W seems ridiculously high for not having any effect on the scene. But you have set a Custom Distance of 47 m... are the objects more than 47 m away from the light? How large is your scene? $\endgroup$ Feb 13 at 12:08
  • $\begingroup$ Hello maybe share your file? blend-exchange.com $\endgroup$
    – moonboots
    Feb 13 at 13:03
  • $\begingroup$ @Mikkel Yes, the dimensions have an effect on how objects receive lights and cast shadows, but in your scene it looks as if there were no lights, shadows or anything like that at all. Please stop discussing this topic in the comments section below an inocrrect answer, rather follow moonboots' suggestion to upload your file. We cannot ask for every possible setting you might have tweaked. $\endgroup$ Feb 15 at 6:42
  • $\begingroup$ @GordonBrinkmann Thanks. Good idea. My file is to heavy for blend-excgange (122 mb), so here is a wetransfer-link. I really appreciate your help, thanks! Mikkel we.tl/t-8NsRG9dCin $\endgroup$
    – Mikkel
    Feb 15 at 12:30

2 Answers 2

0
$\begingroup$

You have multiple problems in your scene. First of all: why is Shadows > Light Threshold set to a ridiculous high number of 100? Set it to the default 0.01:

light threshold

Secondly, your scene's dimensions are still quite large, the spotlight with 700 W quite weak (but also the large Radius size makes the energy spread over a larger area and therefore darkening the light). But even if you set it to 10000 W, you have disabled the Scene World for the Rendered view. Which means, although you have set the world to black, the scene is lit by a default HDRI from the Material Preview mode which is bright enough to make it hard to see the faint light of the spot. If you want the world black, enable Scene World. If you want the scene to be illuminated by an HDRI, you have to do this in the world settings - the default preview HDRI will not be used for rendering so your world environment is black. But note: HDRI environments throw no shadows in EEVEE, you need light objects for that.

scene world

And even when you change all this - perhaps also make the scene smaller to get better lighting (by the way the objects will not throw shadows when they are already in the dark, because the spot points away from them) - then you will not be able to render the scene and get an error "no render output node in scene" when you hit F12, because the Compositor is set to Use Nodes, but the nodes have been deleted. So either disable it if you do not want to composite anything after rendering, or add at least an Input > Scene > Render Layers node and an Output > Composite node to the nodetree and connect the two Image sockets.

compositor settings

Other less important issues are for example, your blue plane object has its Alpha set to < 1, so it is semitransparent. But in the Material Properties > Settings the Blend Mode is Opaque, so it will not show any transparency.

I only wonder why you have changed so many settings that would have worked by default when you do not know what they are used for...?

$\endgroup$
-1
$\begingroup$

Looks like you might be in the wrong Viewport Shader. Try clicking on Material Preview, third from the left.

enter image description here

$\endgroup$
6
  • $\begingroup$ It stil doesn't show the shadows. But thanks :-) $\endgroup$
    – Mikkel
    Feb 13 at 0:11
  • $\begingroup$ Could you give me a little more background on your problem? How long has it been like this? Was it only after you split the screen? $\endgroup$ Feb 13 at 0:29
  • 1
    $\begingroup$ The screenshot shows he is in Rendered view mode, this should show shadows... more than Material Preview at least. $\endgroup$ Feb 13 at 12:02
  • $\begingroup$ True. I was curious about the split screen on the right, where there's no color. I couldn't see the Viewport Shader settings. $\endgroup$ Feb 13 at 16:29
  • $\begingroup$ @GordonBrinkmann My scene was very big, but now I have resized it so the object is 8x11x111 meter. Maybe it's still to big? Does that affect whether you have the opportunity to see shadows and light? Thanks $\endgroup$
    – Mikkel
    Feb 14 at 16:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .