0
$\begingroup$

This is the exact same file loaded in both versions.

Somehow, some way, just updating Blender has ruined my work flow. I can't see what I'm stenciling anymore. I need to move to 3.6.5 for newer geo-node tools, but this is stopping me.

I know it isn't anything wrong with the resolution of the texture decal image. It's at 4096x4096, which was more than enough originally. It was perfectly fine in 3.0.1, but now in 3.6.5 it's a mess of blurry pixels. What happened? Did some default setting change? Is this a glitch/bug?

IMPORTANT: I can still paint with the stencil and it is clear and crisp in the render view as I expect it to be. It's only in the material view where the textures are borked like this.

Here's a download of the file in 4.0.2:

Update broke texture paint resolution.

$\endgroup$
5
  • $\begingroup$ Updated to 4.0.2 and the problem still persists. $\endgroup$
    – DanS
    Commented Feb 7 at 16:21
  • $\begingroup$ I have found a work around, but it does not answer why this is happening to begin with. In the material properties window on the right, with the segment selected, I changed the Viewport Display settings for Blend Mode to Alpha Clip. Unfortunately, this still has problems with stenciling, but I can work with it. $\endgroup$
    – DanS
    Commented Feb 7 at 18:57
  • $\begingroup$ Please consider sharing your .blend file with us, you can do so by packing your texture in the .blend and then uploading it to Blend-Exchange and edit your post to add the provided text. $\endgroup$
    – Lauloque
    Commented Feb 7 at 19:20
  • $\begingroup$ @L0Lock I'm trying, but the upload stalls out. I've tried 5 times now. My file is only 19MB, so it must be either slow internet, or the service you linked to is being throttled by my provider for some reason. I'll continue to try. EDIT: Got it. Link is in OP $\endgroup$
    – DanS
    Commented Feb 7 at 19:53
  • $\begingroup$ @L0Lock I forgot to take off the Blend Mode > Alpha Clip change in the file upload. Sorry. Just disable it to see the problem. $\endgroup$
    – DanS
    Commented Feb 7 at 19:58

1 Answer 1

0
$\begingroup$

The issue seems to come primarily from how Eevee (used by the Material view) renders transparency from image textures.

Setting your viewport's texture anisotropic filtering to a higher value seems to help a lot:

enter image description here

Playing with the material's Blending Mode have only a slight relative impact:

enter image description here

$\endgroup$
4
  • $\begingroup$ Neither of these made any difference, no matter how many different combination of settings between them I tried. Setting the Material Property's Viewport Display > Settings > Blend Mode to Alpha Clip got me closer to how it was in 3.0.1, but is separate from your suggestions. $\endgroup$
    – DanS
    Commented Feb 7 at 19:03
  • $\begingroup$ I updated my answer. $\endgroup$
    – Lauloque
    Commented Feb 8 at 3:29
  • $\begingroup$ That worked. I don't understand what happened in the update to get it that way, but the textures are crisp again. Thanks. $\endgroup$
    – DanS
    Commented Feb 8 at 15:35
  • $\begingroup$ Could simply be that the default value was changed. $\endgroup$
    – Lauloque
    Commented Feb 8 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .