3
$\begingroup$

Using Blender 4.0.

Upon duplicating my collection, the operation seems to work, but the duplicated rigidbodies are not automatically added to the Rigid Body World, which is the basic behavior whenever a rigidbody is created.

Is there a fix for this like a script that adds all rigidbodies in the scene to the Rigid Body World? For what I'm trying to do, painstakingly adding every single duplicated collection to the RBW would be a nightmare.

Based off of my previous question ( How can I create a large amount of ragdolls (a collection consisting of many rigidbodies and constraints) more conveniently? )

Thanks!

$\endgroup$

1 Answer 1

4
$\begingroup$

I guess the main problem will be to get all duplicated rigid bodies selected. Perhaps you could do this by disabling all collections without rigid bodies and then pressing A in the 3D Viewport or the Outliner to select all that are left. Or create a new collection, put all collections containing rigid bodies inside the new collection and right-click on it and choose Select Objects.

But for making the physics work again for these objects: There is a way to link all selected objects to the Rigid Body World. By default the collection called "RigidBodyWorld" is not linked to the scene. However, you can change that:

The Display Mode for the Outliner is usually View Layer. In this mode you can only see collections that are linked to the scene. If you switch this to Blender File, there you will the "RigidBodyWorld" under Collections:

display mode blender file

If you now right-click on "RigidBodyWorld" you can choose Link to Scene from the context menu. This will link the collection to the scene so that it becomes visible when you switch the Outliner back to View Layer. Just be aware that it will be put inside whatever collection was selected before you changed to Blender File. Therefore you might want to make sure before switching that you have selected the top level Scene Collection.

link collection to scene

Result:

rigid body world linked

Now, I forgot to do this before, but anyway: the collection "objects" holds some rigid body objects. After duplicating the collection like you noticed, the duplicated objects are still rigid bodies but not inside the "RigidBodyWorld" collection.

What you can do now is either select all objects in the duplicated collection in the Outliner and drag them onto the "RigidBodyWorld" collection - if you hold Ctrl while doing so, as the tooltip says this will link the objects to the collection so that they are not removed from their original collection:

linking objects in outliner

Another option would be after selecting all duplicated objects in either Outliner or 3D Viewport to link them while you are in the viewport. Press Shift+M to open the Link to Collection menu and select the "RigidBodyWorld" collection there:

link in viewport

By the way, just pressing M to move them inside the collection is the same as not holding Ctrl when moving the objects in the Outliner: this way they are taken out of their original collection and only be inside the "RigidBodyWorld". The physics will work with this as well, it is just a question of keeping them inside a separate collection for organization or if the collection is used somewhere else as well.

Furthermore you could now right-click the "RigidBodyWorld" and choose Unlink to no longer have it displayed in the Outliner. The rigid body simulation will keep working on all objects now linked to it. The only problem is, if you moved the objects there and they are no longer in any other collection, they disappear from the scene when you unlink the "RigidBodyWorld".

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .