I am trying to RIGIFY a human model with a BASIC HUMAN (META-RIG). When I select RIGIFY, the RIG becomes incredible small and it is not even a proper rig. I do receive the attached error. I have not deleted any bones. enter image description here enter image description here enter image description here

Does anyone how to fix this please? Thank you very much.

  • $\begingroup$ Did you apply the scale to the armature after scaling it to fit your model? - In Object mode, select the armature and hit Ctrl-A > Scale. $\endgroup$
    – John Eason
    Commented Feb 4 at 12:07

1 Answer 1



It seems that you get the same error as Rigify Generate Rig Error Index 0 Out of Range 2.83.

blr's answer should help you

  • $\begingroup$ This worked. Thank you!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! $\endgroup$ Commented Feb 4 at 16:35
  • 1
    $\begingroup$ If it worked for you, don't hesitate to accept my answer and marked the question as solved. $\endgroup$ Commented Feb 4 at 16:55
  • $\begingroup$ @user2770097 Hello and welcome. This site is not a regular forum, please don't reply "Thanks" as an answer or comment, instead upvote the post that helped you. If you feel it completely solved your issue consider marking it as accepted. $\endgroup$ Commented Feb 5 at 11:30
  • $\begingroup$ @Squelletton Please don't quote other users answers to avoid duplication and scattering information $\endgroup$ Commented Feb 5 at 11:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .