0
$\begingroup$

I wanted to create a model in blender and export it into unreal to do something.

I first wanted to create windows on a wall with boolean generators. But it has some weird effects after being exported into unreal. enter image description here enter image description here

So I tried to split the walls into pieces and join them afterwards, but it looks like the unreal still treats them as separate objects. enter image description here enter image description here

My question is: how should I exactly join those meshes into one piece (the edges only exists around the windows and outside area) without those weird lighting effects? Thank you!

$\endgroup$
6
  • $\begingroup$ I think we'll need to see your Blend file. You can share it via blend-exchange.com following the instructions there to copy the link on that page. Then edit your question here and paste the link into it. $\endgroup$
    – John Eason
    Feb 2 at 14:29
  • $\begingroup$ @JohnEason I think they are very simple. In my second approach, each window is just surrounded by four meshes. How should I "join" them in a way such that I can treat them as a single piece without those redundant edges in between? $\endgroup$
    – CryForGG
    Feb 2 at 14:47
  • $\begingroup$ This is a problem with normals. It's not in Blender, but in Unreal, so you should probably solve it there. $\endgroup$ Feb 2 at 15:07
  • $\begingroup$ Since you haven't included an image of your object in Edit and wireframe view it's still difficult to advise which is why I suggested that you share yor file. $\endgroup$
    – John Eason
    Feb 2 at 15:09
  • $\begingroup$ For joining the faces: faces cannot have holes. A hole needs to be connected to at least two outer vertices, see dozens of questions on this topic, for example: blender.stackexchange.com/questions/210059/… blender.stackexchange.com/questions/211241/… blender.stackexchange.com/questions/48954/… $\endgroup$ Feb 2 at 15:12

1 Answer 1

0
$\begingroup$

Check if there are overlapping vertices. Press A to select everything, press M to merge, and select By Distance.

If anything weird happens, you may need to change the merge distance to something smaller, like 0.01m or 0.001m.

$\endgroup$
7
  • $\begingroup$ What do you mean by "overlapping vertices"? Two meshes are connected, then their vertices must be overlapping. Or am I understanding it incorrectly? If I merge them, blender just tells me "0 vertex deleted", so I assume it is not the problem you said. $\endgroup$
    – CryForGG
    Feb 2 at 16:09
  • $\begingroup$ If it says “0 vertex deleted” then yes it is not that. I suggested it because sometimes the two meshes can appear to be connected, when in reality they are just overlapping each other, which can cause shading issues. I suggest checking the normals, by selecting everything, and pressing Shift+N to recalculate normals. $\endgroup$ Feb 2 at 16:12
  • $\begingroup$ I don't see a difference after recalculating the normals. I feel that I might just be missing some settings. Or maybe it helps in changing export/import settings? $\endgroup$
    – CryForGG
    Feb 2 at 16:22
  • $\begingroup$ What format are you exporting it as? If you have the option, try selecting the option to triangulate the mesh when exporting $\endgroup$ Feb 2 at 17:58
  • $\begingroup$ I'm exporting it as .fbx file, object types only meshes. In geometry, the setting is "normals only" + "apply modifiers". Which option should I enable here? $\endgroup$
    – CryForGG
    Feb 2 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .