0
$\begingroup$

I have researched for over 2 hours on this topic. I have an animation that I wanted to loop. I looped it with the NLA editor but when I got back to the timeline, the keyframes were gone! Holding the MMB (middle mouse button) and panning up does not fix my problem. The animation still plays. Here is a video. And yes, I know my animation is simple. I am trying to find the answer because I want to pursue more complicated projects in the future.

Video

$\endgroup$
3
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ Feb 1 at 22:00
  • $\begingroup$ I don't know how to add images or gifs $\endgroup$ Feb 1 at 22:59
  • $\begingroup$ There are two links in my comment above explaining how $\endgroup$ Feb 1 at 23:20

1 Answer 1

0
$\begingroup$

It looks like you need to click on the character's rig to view the keyframes. Pause the animation, click on the armature, and the frames should show up. I just opened a couple of my files and I couldn't see the keyframes until I clicked on the rig.

You can check the comments for further answers.

$\endgroup$
15
  • $\begingroup$ Yes. I am positive that I have clicked on my rig. I have been trying to fix this problem for a while now, and that was one of the first things I did. But thank you for the suggestion (: $\endgroup$ Feb 1 at 23:00
  • $\begingroup$ Have you tried appending it to a different file? What about opening it in a different Blender update? $\endgroup$ Feb 1 at 23:35
  • $\begingroup$ I can try that. How do you append something? Do you copy it and then paste it into another blender window? Do animations transfer? Also, how do I open it in a different blender update? And would the fact that I use MCprep addon have anything to do with it. $\endgroup$ Feb 2 at 1:14
  • $\begingroup$ Open Blender. Under the File tab, click Append. Once the Blender file view opens, go to the folder your animation is stored in. Click on your file. It will take you to a long list of file names. Click on the one that says Collection, then click Append. Your character and its rig should pop up in your file, along with the animation attached to your armature. In the viewport, try clicking the rig and then hitting play. Your animation should play and the keyframes should show up in the timeline. $\endgroup$ Feb 2 at 1:24
  • 1
    $\begingroup$ I fixed it! I exported the model as fbx then re-imported it. The keyframes are now there. But, in case someone has the same problem, how do I make this question awnsered. $\endgroup$ Feb 2 at 18:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .