6
$\begingroup$

I want to create an environment texture from a cube map, so I create a cube then map the textures like this: Cube map

But inside the cube, where I put the camera, I can see a black line at the edge's position.

Edge line

After render, this line is visible at final result too.

The line at the result texture

volvis told me to change mapping mode, but I use Cycles Render, so I can not find where is mapping node setting.

Texture setting

$\endgroup$
7
$\begingroup$

I wager that this is caused by the image mapping. Textures are set to repeat by default, and the dark line looks like the bottom part of the texture bleeding to view. Try changing the image mapping mode to Extend or similar and see if that works for you.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for the answer, but I use Cycles Render, so I can not find the mapping node like you said. I have added my texture setting screenshot into the question. $\endgroup$ – Trung Dong May 20 '15 at 6:04
  • $\begingroup$ Ah, true, Cycles seems to be missing those options. I'd consider switching to Blender Internal for this one time. Your other option would be to scale the UVs down one tiny smidge - just enough to hide the tiling artifact - but you'll lose some image data in the process. $\endgroup$ – volvis May 20 '15 at 6:16
  • $\begingroup$ It worked! Thank you very much! It lose some image data like you said, but it's very hard to notice (not visible like the black line). $\endgroup$ – Trung Dong May 20 '15 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.