16
$\begingroup$

I followed the guide here: How do I bake a texture using Cycles bake

I unwrapped my UV, created a new image, created an Image Texture node and selected my new image with that, and hit bake. I then receive the error in the title. Here is a screenshot of my view: enter image description here

I'm definitely doing something wrong, hopefully one of you can point out what that is.

$\endgroup$
3
  • 2
    $\begingroup$ You have empty material slot maybe that's the problem? $\endgroup$
    – Denis
    May 18 '15 at 21:55
  • $\begingroup$ That worked! Thanks Dennis, I appreciate the answer. You can go ahead and write one and I'll mark it. $\endgroup$ May 18 '15 at 22:05
  • $\begingroup$ Try to go to the top of the bar and switch the cycle renders to Blender Render $\endgroup$
    – user64555
    Nov 11 '18 at 3:31
15
$\begingroup$

For baking in cycles each material slot requires image texture in the node setup, and it looks like even if the material slot is empty. To fix the error, remove the empty material slot from the object.

$\endgroup$
6
  • $\begingroup$ Do you think this should be reported as a bug? $\endgroup$ May 18 '15 at 22:20
  • $\begingroup$ @RayMairlot That's quite rare for experienced user to have something like that. I dont think that will be considered as a bug because logically that's how it supposed to work. $\endgroup$
    – Denis
    May 18 '15 at 22:36
  • 6
    $\begingroup$ I'm not a fan of the above comment. You shouldn't have had to hack your way through this issue and it's unclear messaging multiple times to be able to avoid it. Bake should either be more intelligent, or at least be a lot more clear with the error messaging. $\endgroup$
    – Tyguy7
    Aug 1 '19 at 23:10
  • $\begingroup$ I have the same issue, but I'm new to blender and have no idea where an empty material slot is? More help is definitely desired for newbies! $\endgroup$
    – CromeX
    Mar 31 at 21:24
  • $\begingroup$ O geez that is dumb.. have to have the node with an image texture selected.. Maybe update the error comment $\endgroup$
    – CromeX
    Mar 31 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.