1
$\begingroup$

I'm trying to use CrowdRender to render across multiple Macs. All the macs are on the same local network. They are connecting to each other and rendering correctly so long as I pack all textures into my .Blend project file.

But apparently Blender does not support packing video textures (eg .mp4 files).

So I have made sure my .blend file is on the shared drive, and set it to "remap relative" (which I think is the new term for "relative paths"?) As suggested here.

I have placed my texture .mp4 file in the same shared directory as the .blend file.

I have dragged and dropped the .mp4 into the shader window in Blender to ensure that it is referenced from the networked drive.

I've made sure each mac has succesfully mounted the shared drive in its Finder.

So far, I'm still seeing pink missing textures when I try to render video textures.

Is this the correct way to refer to a texture file into Blender from a shared drive?

/Volumes/Drivename/foldernames/texture.mp4

or is it

smb://server.name/path/to/folder/texture.mp4

or something else?

If anyone has experience of running CrowdRender on Macs and successfully sharing video textures, I'd really appreciate it

$\endgroup$

1 Answer 1

0
$\begingroup$

What CrowdRender does on render nodes/workers

Crowdrender places a copy of your blend file on each worker/server/render node (has many names, basically the other computers that render for you).

This copy lives in \Users\<your user name>\cr\server\<unique file ID>\

Problem

If you're using relative file paths, then its highly likely this won't work or you'll have to setup your master/client machine carefully.

Proposed solution

I'd suggest instead, asking Blender to use absolute paths. So long as each worker has mounted the shared folder with the same name, then you should find you can get this to work.

Here's a quick recipe;

  1. Go to Blender's preferences, then the Save and Load section, in the Blend Files section, untick Default To Relative.
  2. Create a new project, a simple one where you just add the video texture to a plane, and add a camera and light so you can render and see if the texture is visible.
  3. Connect to all your workers/render nodes and make sure they are synced or at least sync fail (sync fail is a warning, you can render in this condition).
  4. Try a single frame or animation render to test if the texture is visible.

Making your current project work

Once you have this working, then next thing you'd likely want to do is to get your existing project to work. This is a bit trickier since it will be using relative paths still. The recommended changes above to Blender's prefs don't change your existing projects, just the defaults for new ones.

To change your existing project, you'll need to open it, and then change the paths used. You can do this for an image texture used in a shader by going to the texture node, and pressing open to open the file browser, then select the file on the share drive.

To check that you are indeed about to use absolute paths, in the file browser window, click the gear icon in the top right of the window. You should verify that the Relative Path setting is now cleared.

That method works well if you have only a few textures, if you have a complex scene with a lot of external references, you can go to Blender's File menu, then External Data and choose the Make Paths Absolute command which should change all the paths to their absolute equivalents.

Bear in mind though that this only works if each asset (texture, HDRI, etc) used is already located on the shared drive. This would be the sensible option if you'd already made your blend file using the share drive location for each asset, but haven't changed the paths to absolute.

Using this command would save you time if you had a lot of assets used in your scene.

$\endgroup$
1
  • $\begingroup$ Thanks for the reply - I will try this! $\endgroup$
    – tomh
    Commented Feb 9 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .