2
$\begingroup$

I'm using Blender 2.73 on MacOS.

I've been happily blending away for months since the last time I had a prob with modifiers. But not much issue lately. Suddenly I had a crash (I was subsurface-modifying and it went into a perpetual spin that wouldn't finish.)

I lost some work, but picked up from my last save again and kept going. As I came to the steps where I need a few boolean difference operation, I couldn't use it anymore - it's shaded red (see pic) and it failed to apply.enter image description here

I added a cube and tried with that, and it failed to apply also.

I created a new empty file (below), and it also shows boolean as red, and when I try to apply, it does strange things. Intersect instead of difference etc.
red boolean

Here's a copy of the file for download - just two cubes. Can you see some setting that's precluding me from using the boolean modifier or making it behave weirdly?

Question then is what does the red shading indicate? I searched the docs for "boolean modifier" and "red" and can't find any explanations. Googled wildly without any success.

$\endgroup$
  • $\begingroup$ can you share the specific geometry that refuses to boolean? $\endgroup$ – zeffii May 18 '15 at 15:44
  • $\begingroup$ Yes - here's the link sendspace.com/file/64z8na Verified again that it's a closed object. I was trying to punch the two smaller blocks out of the large flat one. $\endgroup$ – RossGK May 18 '15 at 16:20
2
$\begingroup$

It's red because there's no object selected to Boolean with. When I picked the other Cube it worked fine.

enter image description here

The "Cannot Execute Boolean" is because of this beauty:

enter image description here

In this case the geometry was obviously a bit untidy. But it can happen that this similar situation happens at much smaller scales, which are less easy to see without zooming in. In this case the manifold check in the 3d printing tools doesn't pick it up either.

$\endgroup$
  • $\begingroup$ Aha! I didn't inspect the geometry close enough for weirdnesses. Result of over-doing my bevel. Thanks for sleuthing that out for me. :) Prob worth updating my version too, as recommended. $\endgroup$ – RossGK May 18 '15 at 16:37
  • $\begingroup$ If you aren't updating Blender every 2 or 3 weeks you are doing yourself a disservice :) $\endgroup$ – zeffii May 18 '15 at 16:52
1
$\begingroup$
  • Red color. The Boolean modifier needs you to specify the other cube for [OBJECT] in the panel. The red means you have not satisfied the requirements of the panel for it to execute. User Error. If you want A intersects B. You must specify B in the panel. Simple problem now that someone else looks at the image.

  • For the other first failure. Make sure that both objects are closed objects. Start with simple closed objects and then progress to more complex objects.

$\endgroup$
  • $\begingroup$ It's possible I never noticed the red colour to the modifier until I started having a problem - so that's poss a red-herring (:/) Wish that info were in the docs. Regarding the failures though, the object is closed ( I do a 'select non manifold' and can verify that it's a closed object to be certain. I also checked all normals which are fine. $\endgroup$ – RossGK May 18 '15 at 16:17
  • $\begingroup$ @RossGK consider video tutorials on a video website as part of the total COMMUNITY documentation. Every person here has wisely seen or created video tutorials. Blender.org written documentation is not going to receive any awards. Its unlikely that a software writer will provide high quality documentation. I digress. Perhaps you and I can create an organization to give documentation awards to Blender.org. You probably would want to learn the basics of hammering by watching someone hammer first. The fine points can be discussed here at Blender Stack Exchange. $\endgroup$ – atomicbezierslinger May 18 '15 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.