1
$\begingroup$

enter image description here

I just added the automatic weight to the model succesfully however i am adding weight to the bones as u can see here...however i have been stuck on red for a while and cant get the red to go into place...anyone got any ideas?

$\endgroup$
5
  • $\begingroup$ Hello could you please share your file? blend-exchange.com $\endgroup$
    – moonboots
    Jan 24 at 17:53
  • $\begingroup$ What exactlly do you mean by "stuck on the red"? If you want to replace a red area with blue just turn the Weight setting in the top bar down to zero and paint the section that you don't want the selected bone to influence so that it's fully blue. $\endgroup$
    – John Eason
    Jan 24 at 18:00
  • $\begingroup$ <img src="https://blend-exchange.com/embedImage.png?bid=WrjwwvS2" /> here is the file $\endgroup$
    – Full Salvo
    Jan 25 at 14:04
  • $\begingroup$ i dont meant that its stuck on red...it just wont go into place $\endgroup$
    – Full Salvo
    Jan 25 at 14:05
  • $\begingroup$ [link] (youtu.be/llv68gVPuZA) here is a video better explaining my issue $\endgroup$
    – Full Salvo
    Jan 25 at 14:13

2 Answers 2

0
$\begingroup$

For an object like a robot, weight painting is not a good idea because it's long and you're going to assign some vertices to the wrong vertex group. For this kind of object, it's better to directly assign to the good vertex group. Generally you'll parent With Empty Group, then select the vertices, select the vertex group and click on Assign.

In your case, if you just want to assign the forearm only, first check the name of the bone (it is lower arm l, which is not a good name, rename with the _l or .l suffixe instead), then select all the vertices of this part (make sure that you don't forget any vertex), then in the Data panel > Vertex Groups > Remove from All Groups:

enter image description here

Then assign to the correct group:

enter image description here

$\endgroup$
4
  • $\begingroup$ okay...i think i see what ur saying...follow up question...how do i select the specific parts like you did in the images without picking up the background stuff like pieces of the leg area or p[arts of the area that i want to be the upper arm/hand? $\endgroup$
    – Full Salvo
    Jan 25 at 16:38
  • $\begingroup$ cause when i do left click hold and select an area it picks up part of the leg area and parts of the upper arm area $\endgroup$
    – Full Salvo
    Jan 25 at 16:41
  • $\begingroup$ Use L to select a separate part of the mesh (if this is what you mean) $\endgroup$
    – moonboots
    Jan 25 at 17:00
  • $\begingroup$ thank you...i think i got it now $\endgroup$
    – Full Salvo
    Jan 25 at 17:18
1
$\begingroup$

In weight paint mode, brushes can have struggles with overlapping geometry.

In the Brush menu disable the "Front Face Only" option, and in the Falloff menu change the shape from "Sphere" to "Projected".

In this way the brush will affect everything is under the cursor circle (even unwanted areas, so be aware).

Remember that weight is affecting vertices, not faces, turn on wireframe overlay to check where exactly vertices are.

If this doesn't solve, try directly assigning weight in Edit mode for problematic areas.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .