0
$\begingroup$

I want to render a model that has overlapping polygons. The viewport and Cycles render show artifacts wherever the overlaps are. Is there a way to fix that in the render settings?

Viewport viewport

Render Render

Cheers!

$\endgroup$
3
  • 1
    $\begingroup$ That's called Z-fighting and is because Blender can't decide which surface to render because they're both in the same position. Either move one of the surfaces up fractionally so that it's in front of the other or disable one of them when rendering. $\endgroup$
    – John Eason
    Commented Jan 24 at 12:02
  • $\begingroup$ Thanks. Regretfully the model is made by another program and there are hundreds of the overlaps it outputs. Is there a way to select a group of objects and have blender boolean them all together to one mesh? $\endgroup$
    – hal
    Commented Jan 24 at 12:19
  • $\begingroup$ Select your final object then Shift-box-select all the others in wireframe mode (Shift-Z) making sure that you don't include any lights or cameras. Ctrl-J will then join them into one object but it won't solve the problem of overlapping faces. $\endgroup$
    – John Eason
    Commented Jan 24 at 12:31

0

You must log in to answer this question.