This question already has an answer here:

I know that nobody likes duplicate questions, but I haven't found my answer on any of the other questions with this topic.

I built a computer with a GeForce GTX 750 GPU (made by Gigabyte). It supposedly has 512 CUDA cores. I followed this tutorial, (which enabled the Nvidia proprietary drivers) and was able to enable dual monitors and all the desktop graphics that are needed. Unfortunetly, the GPU processing option still doesn't show up in Blender. I've tried installing nvidia-cuda-toolkit, and that didn't make a difference. I also tried to update my drivers from nvidia-346 to nvidia-349, and this had no apparent effect either. What can I do to enable GPU rendering? (I've tried both blender installed and just downloaded from the site).

marked as duplicate by gandalf3 Jul 27 '15 at 18:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Cuda seems not to be available unless you start is as root. Open a console and run: sudo blender. Then you'll be able to enable cuda rendering in the user preferences. The weird thing is that if you close the blender and re-open it as a regular user, then cuda is accesible. – cegaton May 18 '15 at 14:20
  • 1
    The trick was, since I couldn't use the installed version from the software manager, to actually type in the entire directory, and then blender at the end. I just opened the containing folder in the terminal, and then typed sudo blender, and it didn't work. So, even if you are in the folder, you need to type the entire directory (if you are using the downloaded executable from blender.org). Thanks! – Anson Savage May 19 '15 at 14:30
  • starting blender with sudo will not be a good solution for everyone. keep in mind that all the rendered / saved files will be owned by root. – Madlaina Kalunder Apr 20 '16 at 13:15

You will need to install the package nvidia-modprobe which (I believe) allows Blender to detect your nvidia CUDA device. This is applicable to Mint, Debian and Ubuntu, I don't know about other distributions of Linux:

sudo apt-get install nvidia-modprobe

You can also install nvidia-modprobe via your favourate package manager. Please use the Nvidia drivers from the standard repo, the drivers from their website are not auto updated. Doing sudo blender for one feature is non-optimal :) and means that all your .blend files and exports will be owned by root. This is inconventient.

Note that Blender+Nvidia+CUDA requires nvidia-cuda-toolkit, nvidia-modprobe and the proprietary drivers.

Edit: Mint doesn't have a nvidia-modprobe package.

Download the nvidia-modprobe coresponding to your nvidia driver from here then extract it. Use a terminal to navigate (use cd [dir] to navigate) to the folder where you extracted the file. Run make and then run sudo make install to install nvidia-modprobe.

Alternatively use this to download and install the Ubuntu nvidia-modprobe package (not recomended):

wget -c "http://mirrors.kernel.org/ubuntu/pool/multiverse/n/nvidia-modprobe/nvidia-modprobe_340.24-1~ubuntu14.04.1_i386.deb" -o "nvidia-modprobe.deb"

And then:

sudo dpkg --force-install nvidia-modprobe.deb

You will need to reboot afterwards. This should install the right package. You might want to submit a bug report to the Mint17 people for not including nvidia-modprobe.

  • 2
    nvidia-modprobe can also be installed using the software manager. That was indeed the missing piece! Thanks for pointing that out. No more sudo .... – cegaton May 19 '15 at 17:24
  • Thank you for the answer. I tried that, and it said, "E: Unable to locate package nvidia-modprobe". I also searched for it on the software manager. – Anson Savage May 20 '15 at 4:56
  • Can I install it from this website? download.nvidia.com/XFree86/nvidia-modprobe I extracted the file, and it didn't seem to work yet. Thanks! – Anson Savage May 20 '15 at 5:01
  • @AnsonSavage That is strange... are you using xorg-edgers? in which case you would have no nvidia-modprobe package. Perhaps nvidia-modprobe is not in the Mint17 repo? – Amziraro May 20 '15 at 5:13
  • 1
    @AnsonSavage I have modified my answer to support Mint 17 and other nvidia-modprobe'less distros. – Amziraro May 20 '15 at 5:28

I've had trouble with some versions of the Nvidia drivers.

In order to get GPU rendering to work with my GTX 780 on Mint 17 (Qiana) I've had to disable nvidia-331 driver updates through the Update Manager, and keep it at version 331.38-0ubuntu7

  • This addresses my question about why my system (Linux Mint 17.3 Rosa-16-bit/GTX-960 running nvidia-352.63 driver, CUDA 7.5 installed and showing up in Synaptic as installed) won't show the GPU as an option in Blender 2.76. The question: is the nvidia-352.63 driver supported or do I need to downgrade to get CUDA working? – RobinsSea Dec 20 '15 at 7:15
  • did you find an answer for that? I can't get it to run on one machine out of 5 and i don't know what to do anymore. it works sometimes though. – Madlaina Kalunder Apr 14 '16 at 15:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.