1
$\begingroup$

So I'm modelling a water fountain and currently I working on adding some water in the form of a Blender Fluid Simulation. Everything looks more or less as expected except the water stream coming from the pipe. What I get is this weird stream looking like it is a string of spheres (left part of the picture). What I want is a more or less even water stream (right part of the picture). So I actually managed to get what I wanted but only for (too) small initial velocities.

EDIT: See my own answer for my solution

I tried changing between FLIP and APIC and of course also played with the resolution but no real change happened.

What can I do to achieve that smooth water stream but with high enough velocity so that it does not look like a tap that has too little water pressure?

The water not doing what it is supposed to

$\endgroup$
4
  • 1
    $\begingroup$ Try increasing the subframes. $\endgroup$
    – Leander
    Jan 19 at 15:51
  • $\begingroup$ @Leander Do you mean Sampling Substeps in the emitter properties? Or where do I find the subframe option? $\endgroup$ Jan 19 at 16:08
  • $\begingroup$ By subframes, look at the Fluid Domain Resolution Divisions. Most people think that the default of 32 is not sufficient. Try doubling this. Also look at increasing the Mesh Upres factor from default of 2 (start with 4). $\endgroup$
    – james_t
    Jan 19 at 20:22
  • $\begingroup$ @james_t So it seems like rising the Mesh Upres Factor actually makes it worse. With 4 it really just is individual spheres flying out. Though increasing Particle Radius in Relation to Upres Factor smoothes out everything, only that it looks now like thick oil or honey $\endgroup$ Jan 20 at 11:02

1 Answer 1

1
$\begingroup$

So by trying out a bit more it seemed like decreasing the Time Scale (from 1 to 0.3) actually helps a lot. Additionally increasing the Minimum for the Adaptive Time Steps from 1 to 2 also helped to reduce the spherical artifacts and the stream now looks really clean. See the image for the relevant settings and the values that solved my problem.

Relevant new settings

$\endgroup$
1
  • $\begingroup$ So many parameters to play with, so little time to throw salt over your shoulder ! $\endgroup$
    – james_t
    Jan 20 at 16:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .