Here's the link to the new .blend file https://www.dropbox.com/scl/fi/6oxo1zcj30o0okcha6bhs/blender-help-2.blend?rlkey=6griezpkni60khnmij8ac3sbd&dl=0

enter image description hereenter image description here

enter image description here

enter image description here

enter image description here

enter image description here

I've been battling this problem all day.

I've baked a fluid simulation and am using it as a brush for the plane's dynamic paint. It looks exactly like what I'm going for in the viewport, but everything looks flat when I go to render. I've seen many posts pointing to the samples being different or using experimental settings but, I've tried all so far and nothing seems to work. All my renders show no small ripples. I've even set up a particle system so that the emitter and objects are also brushes, but no matter what, The smaller ripples won't show up. I'm at a subsurface division of 6 but I've tried 5 and 4 to see the same difference in the render.

update Not sure why, but I deleted my Scene 1 from this file and now notice that waves now bake correctly, but they still do not show in the render.

  • $\begingroup$ To make it appear in render, you have to bake the Dynamic Paint cache on the canvas object. The Bake button will only become available when you have saved the file somewhere (just in case you didn't do that yet and wonder why the Bake button is greyed out). $\endgroup$ Commented Jan 18 at 7:02
  • $\begingroup$ Hey @GordonBrinkmann, I've tried baking dozens of times. When I bake the settings, everything goes flat, even in the viewport. $\endgroup$ Commented Jan 18 at 9:55
  • $\begingroup$ Baking the fluid, baking the dynamic paint or both? I can only speak for my Blender, it works as expected (I baked fluid & paint): fluid & dynamic paint $\endgroup$ Commented Jan 18 at 10:07
  • $\begingroup$ Is the Dynamic Paint modifier on the domain above or below the Fluid modifier? In the Modifiers tab, not the Physics tab (in the physics properties you cannot change the order). But I guess before this gets a long discussion where I'm asking for every detail of what you did exactly (because all information can be necessary or helpful), you should probably just upload the file for inspection here and edit it into your question: blend-exchange.com $\endgroup$ Commented Jan 18 at 10:30
  • $\begingroup$ @GordonBrinkmann I've baked everything and what seems to happen is that when I bake the Wave, it freezes on whatever frame the playhead is on. I've also just tried switching the order in the stack which produces the same result. Before Baking (freezing animation) the viewport looks great. I'm going to upload the file to my Dropbox because the simulations are too large for Stack Exchange. Thanks for looking in. $\endgroup$ Commented Jan 18 at 11:39

2 Answers 2


Your file is 25.2 MB, you can upload 30 MB, and you can always reduce it to the essential parts that are not working. Anyway, it would have been nice and less confusing if your uploaded file had the setup you were asking about in the question (fluid simulation and dynamic paint) to see why this did not work.

But your file uses particles as brushes for the dynamic paint. And there I found a very simple reason why the real render is flat instead of showing waves like in the viewport: simulations, bakes etc. are baked on the Viewport resolution of modifiers. The Subdivision Surface modifier on the canvas object is set to Level 6 for the viewport, but only 4 for the render. If you set it to 6 as well, it shows the waves.

different subdiv levels

In general you can say: the subdivision level for rendering has to be the same which you used for baking. If it is not the same, the waves will not show in render. If you change the level for the viewport up or down after baking, the waves will not show in the viewport (but when you render it, if the render level is the same as used for baking).

The problem with this answer is just that your screenshot shows Level = 6 for Viewport and Render - so this seems to be correct. I do not know if you used that for baking or changed it afterwards or what else you did differently. As I said before, your question is about a fluid simulation, not particles. Which means, if your levels were correct earlier (but you mention changing them) there could have been other problems which are not there now. And although your file has a fluid domain in there, it has no Dynamic Paint enabled - so if I would add it myself this would not tell us if there was something different when you did it.

  • $\begingroup$ Thanks for looking into the file. I've reuploaded the blend file with issues with the dynamic paints. The reason its so large is because of the simulations in question. As you correctly assumed, I had changed the subdiv settings after hours of tweaking to try to find the issue. I've deleted and rebaked both levels at 6 and Im still getting the same issue. Issue 1-The baked animation of the Waves is not animated and only stays on 1 frame. Issue 2-The Rendered image is completely flat vs the Viewport. $\endgroup$ Commented Jan 18 at 13:29
  • $\begingroup$ @AaronJohnson Now that I've got that file I don't know where to start. First of all: the rotation of domains does not work as if the fluid is in a slanted box. Falling down means falling towards the bottom of the box, not global -Z. Also all borders are open, which means as soon as the smaller simulation hits the bottom of the domain the splashes are gone - which means the complete domain is now a fluid mesh because there are no more fluid particles to define the mesh. Then the large domain simulates both emitters, because they are both within the boundaries. Why are there two domains? $\endgroup$ Commented Jan 18 at 14:32
  • $\begingroup$ There is no need to simulate up until frame 250 either when the animation only goes to 92. All in all I would first go and build a proper simulation setup like having the domain(s) rotation cleared, then only using one domain instead of two, then why are the domains animated, jumping in from somewhere else? Delete the animation. Also it might not be necessary but always better to have the scale applied. Then why are they parented to empties? And if you don't want the fluid meshes to suddenly become just a bounding box, the fluid particles have to stay until the end or be made invisible. $\endgroup$ Commented Jan 18 at 14:37
  • $\begingroup$ yea... all the reasonings I have to your questions sound pretty dumb to me this morning. You're right. I think it was a case of feeling too far forward to go back but I should have just redone the simulations instead of trying to move them around afterward. Also thank you for the info on why the particles were turning into the shape of the domain after they animated out. That answers your question on why I needed to animate the domain out of frame. $\endgroup$ Commented Jan 18 at 16:09
  • $\begingroup$ @AaronJohnson I was mostly wondering why it was jumping into frame... the simulation starts at 1, so why leave the domain far off on frame 0? Anyway, I hope my second answer shows how this can work. $\endgroup$ Commented Jan 18 at 17:55

Now with fluid simulation I changed a lot. First of all I removed the animation from the domains, then I removed the rotation from the domain and deleted the smaller domain.

The remaining domain I moved downwards so its bottom is below the canvas object. I enabled the _Border Collisions for the Bottom boundary on the domain so that the fluid mesh will not become a bounding box when all particles are gone through the floor.

domain settings

Then I dissolved the odd vertex on one edge of the canvas plane and subdivided it a few times to mainly get more square-sized faces but also to get a good base resolution before the Subdivision Surface modifier.

Your original plane with that odd vertex:

odd vertex

Your mesh with the Subdivision Surface modifier, still not very highly detailed for Dynamic Paint and somewhat distorted from that single vertex:

low resolution mesh

My base mesh (before the Subdivision Surface modifier!), maybe you could even make it denser:

high resolution

With all these settings, I first simulated the fluid and afterwards baked the Dynamic Paint. Since I changed some of the settings and with the rotation of the domain cleared having gravity pull the fluid down instead of slightly sideways like in your domain, the splashes might not be as you wanted them. But at least they now make waves and they appear in the render. By the way, after baking the waves, switching the plane to Edit Mode and back to Object Mode can clear the cache as well and remove the waves.

My result (had to make my own sky because yours is not packed in the file):



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .