1
$\begingroup$

Ever since I installed 4.0 I've noticed this very weird (I'm assuming) bug in the viewport. It seems like the center view is latched onto something invisible and the viewpoint is being orbited/centered around it, I'm not sure how to describe it.
Whenever I press Numpad 1 and Numpad 3 to snap shift the view it's never properly aligned and ends up in weird angles.
I've also noticed when rotating the camera around in general as well.

How it's supposed to be:
https://imgur.com/0Yhh1UX.mp4

What is happening:
https://i.imgur.com/bZD2VW4.mp4
https://i.imgur.com/VQkq6LW.mp4
https://i.imgur.com/50oJn1z.mp4

This has only happened to me with Blender 4.0, even reverting back to 3.5 I don't encounter this issue.
I've found that if I reset the preferences/defaults back to factory settings, it fixes the issue but only until I close blender, when I start it up again issue/bug immediately comes back.
I've tried editing my preferences with everything in the navigation tab (currently everything is off except for depth) , I've tried a clean reinstall, turned off various add-ons; nothing seems to work and I'm at a complete loss with why it's doing this and how to fix it.

$\endgroup$
2
  • 1
    $\begingroup$ Hello and welcome. Instead of having users go through links and external sites please use the builtin tools to embed images in your post. See How to upload an image to a post? or GIF $\endgroup$ Jan 15 at 22:29
  • 2
    $\begingroup$ It's something to do with your orbit. Restore to factory settings, save startup file, save preferences. There's some particular thing you did somewhere, but that's the easy solution that doesn't require anyone (me) to research things. $\endgroup$
    – Nathan
    Jan 16 at 5:48

1 Answer 1

1
$\begingroup$

The view is only centered on the world's origin as long as the world origin is in the center of the view. That is the case in the latest version and it was like that in older versions.

What you experience here are two things I guess: one seems to be that in the Preferences you have disabled Navigation > Auto > Perspective, so it does not automatically switch from Perspective to Orthographic when you go into front/right/top view by pressing Numpad 1/Numpad 3/Numpad 7 or vice versa, you have to do it manually by pressing Numpad 5.

auto perspective

The other is - as I said before - Blender does not center on the world origin automatically when you have moved the view off-center. And probably you have saved an off-centered view as default startup file, so it comes back to this when you start up Blender.

What you can do in this case: open up Blender to make sure you have a fresh startup scene (not being in a current project with other objects etc. in the scene), make sure your 3D Cursor is in the world center by pressing Shift+S > 1 (Cursor to World Origin).

Then from the viewport menu choose View > Align View > Center View on Cursor. Now you can maybe adjust the view by zooming in or out and rotating it to your liking (but not moving around since this will move the view off-center again).

center view to cursor

After that is done and the view is still centered on the cursor / world origin, go to File > Defaults > Save Startup File. Now every time you start Blender, the new scene will be the one you currently have with the view centered on the world origin.

save startup file

$\endgroup$
1
  • 1
    $\begingroup$ That seems to have fixed it for now after running a few start up tests to see if it was consistent. I'm not sure why it was like that before since I didn't touch anything with navigation before hand.Thank you very much! $\endgroup$
    – panters
    Jan 16 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .