So basically, when I click I I get 3 options for all channels selected and in active group. I don't know where the channels are, except for the video sequence one where I can find all the channels. But I can't select one just by clicking on it, so I basically can't create any keyframes.

I was at the Dopesheet most of the time. And whenever I open Blender and press I it shows up. But then it disappears the second time and only gives the 3 options. I used the animation one at the bottom. So I'm going to have to reopen Blender each time until I completed the animation. That's all I did.

It's Blender version 3.6.9. And here are the options

3 options

And if you cant see them they are All channels, Selected channels and in Active group

  • $\begingroup$ Please edit, to expand this question, describing which editor you are working in.. Timeline? Dopesheet? etc. Preferably embed a screen grab in the post, using the tools provided, and indicate where you are not seeing something, that you expect to see. Then we'll re-open, and be able to help. At the moment, it's a bit too vague to understand unambiguously $\endgroup$
    – Robin Betts
    Commented Jan 6 at 9:50
  • $\begingroup$ Hello. Thank you for the update. Maybe it's only me, but I still don't understand your problem. Can you add a screenshot? (Blender, main menu Window > Save Screenshot). What are "the 3 options"? $\endgroup$
    – Blunder
    Commented Jan 9 at 1:21

1 Answer 1


Two issues here: you are not using the right editor, and you are not in the right context.


Blender always use your mouse cursor position to know where you do an action from and adapt from it.

In the animation editors like the Dope Sheet, Timeline or Graph ; when you press I to add a keyframe, the context is the existing data in those editors, Blender wants to add keyframes in channels. But in your case, there aren't any.

In this case, it can't create new ones. So you need to create keyframes first in the Viewport, or from the properties keyable themselves, which will make the channels you can key from animation editors.


Your Dope Sheet Editor is in Cache File mode instead of Dope Sheet mode, you should change it:

enter image description here

Although personally I would just use the Timeline Editor instead of the Dope Sheet, and open a second area for the Dope Sheet if I really need it - which is rare and most of the time I use the Graph Editor instead:

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .