1
$\begingroup$

I am completely new to using this modifier and have created a simple object and plane (cloth) and using animation got the plane to 'fall over' my object. The problem I have is that the corners do not fall to the base as the middle of the sides do as if the cloth has no 'stiffness'. Are there any settings in the cloth modifier so that all the length of each edge falls to the base. I have tried each of the preset settings (cotton, denim etc) without success.

OR is the only method to select vertices and drag them?

Here is an image with red arrows pointing to the corners which do not fall far enough for my preference (I am trying to create an object which is covered by a tarpaulin.

enter image description here

$\endgroup$
3
  • 2
    $\begingroup$ You don't have enough subdivisions on the plane. Suggest you add a Subdiv Surface modifier to it in Object mode with the Level set to 2 and drag it above the cloth modifier on the modifiers panel. Watch this tutorial for the details. He uses loop cuts rather than subdividing the plane, but that's only really needed to get square faces if your plane isn't square. $\endgroup$
    – John Eason
    Commented Jan 5 at 0:50
  • 1
    $\begingroup$ Thanks John. I tend to try and keep subdivisions to a minimum as usually my objects are only 'viewed' from a distance and total number of faces/triangles or whatever can affect fps (frames per second) in MSFS however in this case as you advise they affect the outcome in Blender. I hope I am assuming that square faces are preferred in Blender - maybe only for appearance? I have never used Subdiv Surface modifier so that is something new for me to know about. Thanks again. $\endgroup$ Commented Jan 5 at 0:59
  • 1
    $\begingroup$ @JohnArnold It is always good to keep the polycount low if you want to save resources, of course a higher polycount affects the performance. But as John said, you need a higher resolution if you want the cloth to look more natural. In the end, the "cloth" mesh can only bend where vertices are - edges are always a straight connection between vertices. So no vertex, no bending. Imagine a plane with only four corner vertices - it behaves like a board. You can try to make it bend more by lowering the values in the Stiffness parameters - but most likely it will not look very realistic. $\endgroup$ Commented Jan 5 at 7:09

1 Answer 1

2
$\begingroup$

As mentioned in the comments, to make a better looking cloth you need a higher resolution of the mesh. But when you do not need the cloth animated but only in its end state and to be seen from afar, you do not have to keep the resolution so high after you have created the cloth.

As an example, this is how a cloth looks like simulated with a plane consisting of 256 faces or 289 vertices - I've set it to Shade Smooth, but still not awesome:

low-poly cloth

So next up, I put a Subdivision Surface modifier on the plane, with Level = 2 and set to Simple (because I only want the resolution without smoothing) and place it above the Cloth modifier. Then I simulate it again, now with a plane of 4096 faces or 4225 vertices.

After the Cloth modifier I put another Subdivision Surface modifier, this time set to Catmull Clark and Level = 1. I put it after the cloth because I do not need that high resolution for the simulation to look good enough and it also simulates faster of course with less resolution. I just use it afterwards to smoothen the simulated cloth. Now I have a cloth mesh with 16,384 faces / 16,641 vertices and the result looks like this:

high-poly coth

Much better in my opinion. But of course this mesh has a very high polycount. So after all previous modifiers I put another one, the Decimate modifier with the default Collapse option and set the Ratio quite low (which of course depends on how much you want to reduce the polycount while still being satisfied with the appearance of the mesh). In this example it is 0.1 or 10% of the original mesh, which results in 2843 faces or 1768 vertices. And I think it still looks quite good:

decimated cloth mesh

So these are the settings of all the modifiers used (apart from the Cloth modifier):

modifier settings

When you are happy with how it looks and do not want to make changes anymore, you can apply all the modifiers and change the mesh permanently. Just select the cloth in the 3D Viewport, press Ctrl+A > Apply > Visual Geometry to Mesh.

Of course this is still a higher polycount than a 256 faces mesh, but thanks to a higher resolution simulation and smoothing afterwards you (almost) get the look of a more than 16,000 faces cloth with less than 3,000 faces. And this is just my example, of course you could try it with different resolutions as well.

$\endgroup$
2
  • 1
    $\begingroup$ An absolutely fantastic tutorial. If I could have ticked 'answer is useful' more times I would have. I was also thinking before I read your tutorial that maybe to reduce the resolution I could use the decimate modifier but had not yet had time to try that out. Your tutorial goes into my 'Blender hints and tips' document. Thanks again. $\endgroup$ Commented Jan 5 at 21:08
  • $\begingroup$ I meant to mention that 3000 faces is very acceptable to me. I have to take into account that in MSFS I have quite a few other objects which will be 'on screen' at the same time and that is why I like to keep the polys as low as possible for each object I create while still maintaining a 'good look'. I use decimate quite a lot reducing the ratio until I loose detail and then 'backoff' a little. $\endgroup$ Commented Jan 5 at 22:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .