4
$\begingroup$

I have been struggling with this simple but naughty problem since a while now. I can do good things in Blender, but I miss simple knowledge, so I'm sure someone can help easily.

Once I have exported a .mhx model from MakeHuman into blender, the textures are not ready for cycles. I can quite easily add the skin by just following these simple steps:

  • In Object Mode, select the body, go in Material > Surface and click "Use Nodes"
  • Replace "Color" with "Image Texture"
  • Select "Young_light...diffuse.png" or whatever the default image is.

Everything works and goes on as planned:

Skin texture on MakeHuman model (Material View)

But when I repeat the same steps for the eyebrows, eyes, and eyelashes, everything turns black instead of using the image texture. Arrg! I tried Ctrl + N to invert the normals, but that doesn't fix anything. The same problem persists in Cycles view. Would anyone please help me here? Thx!

$\endgroup$
  • 1
    $\begingroup$ It seems to me the mesh is missing UV coordinates. $\endgroup$ – cegaton May 16 '15 at 1:19
2
$\begingroup$

I had the same problem for a while but solved all 3... I hope the following helps you...

as you can see this is the end result...

Finished result

The first thing to do is to select each object and make sure the UV's are aligned correctly...

To do this, split the 3D view (I assume you know how to do this) and change the new panel into a UV/image editor, then, select the eyes and with your mouse cursor over the 3D view port, tab into edit mode and press "A" to select all verts...

If you don't see them appear in the UV window then you need to unwrap them (You can find the Unwrap command in the tool shelf of the 3D view port).

I tend to unwrap them anyway just to make sure blender registers the UV maps.

If you do this then I found you will need to re-align the UV's manually so keep that in mind.

You should see them appear in the UV/image editor.

Once you have them aligned go to the UV/image editor panel, look at the bottom edge, just passed the menu options you should see a place to load or link an image.

Click the small page with an image icon to link existing images or load the image texture from wherever it is saved on the disk.

It should already be aligned. Tab out of edit mode and you should be done with the eyes.

Do the same for the eyelashes and eyebrows.

Okay so that's step one out of the way, onto step two...

the same nodes work for all 3 Objects(eyes, brows and lashes), they are as follows;

The nodes

All you need to do is change the textures it uses for each one...

Please vote this up if it helped because it would lift some of the restrictions I have, so I can help others out...

Thank you everyone!

P.S. I have only got this to work with cycles renderer, as of yet I have not got this working with the Blender render engine but am determined and am working hard at it!

$\endgroup$
  • $\begingroup$ Thanks for the answer. I'll come back to you when I try. $\endgroup$ – Denis G. Labrecque Oct 17 '15 at 0:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.