0
$\begingroup$

I'm rigging the compressor machine with 2 cylinders.

3 armatures are used:

Armature 1 has bones parented to piston, rod. Armature 2 parented to crankshaft. Armature 3 is the parent bone for armature 2 for better controll the rotation.

Armature 1~3 work well. Even duplicated them along Y axis, the duplicated one also work well. HOWEVER, duplicated another armatures from 1~3 then flip them to another side (around Y axis) one joint can not work.

enter image description here

From the front view. The joint is not working. enter image description here

The expected result should be: enter image description here

Here is the Blender file。 https://drive.google.com/file/d/142eS4wmDgmHCCVksqCghFNHMTYANyqcq/view?usp=sharing

$\endgroup$

1 Answer 1

1
$\begingroup$

We're comparing the behavior of your file's Armature_001 and Armature_001.001.

These are not the same armature. Armature_001 has IK locks on bones that are not present in the other armature, so it's not a straight duplicate. These IK locks are what keep the first two bones in the IK chains straight, so their absence is why your "duplicate" is rotating those two bones.

enter image description here

We're looking at piston in Armature_001. Notice the IK locks on the properties viewport. Piston in the other armature has no locks.

I can't quite keep my mouth shut regarding some other things here. I would very strongly recommend working with armatures with applied rotation, and against dividing your bones into so many armatures. Spreading out all your bones into multiple armatures like this makes it hard to edit, hard to use, and (most importantly for me right now) hard to troubleshoot. If you ever find yourself using an armature containing only a single bone, you're not doing it right.

$\endgroup$
4
  • $\begingroup$ Thank you Nathan. I tried to set IK Lock on piston_scratch and piston bones of Armature_001.001 in Bone Properties -> Inverse Kinematics -> Lock IK Y and Lock IK Z. But the locks are useless. It should be lock the direction Y and Z. Any comments? $\endgroup$
    – Damon Song
    Jan 1 at 23:52
  • $\begingroup$ It works for me when I lock axes. You should probably sniff around a little further. After that, if you can't figure it out, edit your question or ask a new question focused on why your IK locks aren't working. Provide a file with keyframes demonstrating them not working. Simplify the file to the only bits relevant. Specify the version you're using if not up-to-date. $\endgroup$
    – Nathan
    Jan 2 at 1:36
  • $\begingroup$ Oh I see-- the second armature has different axes for bones as well. Just lock all axes. You don't want them rotating at all. Or if you do, lock the axes you don't want rotating, which depends on the axes of those bones. Enable display of axes in properties/armature/viewport display to see them. $\endgroup$
    – Nathan
    Jan 2 at 3:02
  • $\begingroup$ Fixed. Thank you Nathan. The problem is caused by IK locks on the properties viewport. After 'Flip', the axis of bones are 'fliped' too. As a result, the correct Lock IK should be X and Z. $\endgroup$
    – Damon Song
    Jan 2 at 4:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .