16
$\begingroup$

I created a glass cone with black seams (the seams are a diffuse not transparent material).

render with solid shadow

When I shine light on it, the cone casts a solid shadow. Why is this?

I would like to have a (semi) transparent shadow cast from the glass and a full shadow from the seams.

Here is the link where you can (hopefully) download the blend file:

glass cone

$\endgroup$
  • 2
    $\begingroup$ in the future please share the file in a way that doesn't require permission to download. $\endgroup$ – cegaton May 16 '15 at 5:28
18
$\begingroup$

You did have Transparent Shadows disabled in the Material Settings. Once enabled, you can use the Light Path Node's Is Shadow Ray to Select between the Glass and Transparency shaders to achieve this effect.

enter image description here

$\endgroup$
  • 4
    $\begingroup$ maybe the transparent shader should have the same color as the glass $\endgroup$ – Chebhou May 15 '15 at 18:14
  • $\begingroup$ @MarcClintDion Thanks Marc, looks very good! I've copied your node-structure but it gives me no the same result (I've added the picture in your post). Could it be that I have to edit the material of the plane ? $\endgroup$ – Christophe May 15 '15 at 18:48
  • $\begingroup$ @Christophe Add a link to the pic in a comment to this answer instead of editing it into the answer. Editing your problems into someone's answer, doesn't really help anyone, including you. $\endgroup$ – user7952 May 15 '15 at 19:12
  • 3
    $\begingroup$ I see you marked the answer as correct. I guess this means you got it. That's good because I re-downloaded your file, reset Blender to factory defaults and tried again and it works for me just as before. I'm curious about where your problem was. $\endgroup$ – MarcClintDion May 15 '15 at 19:40
  • $\begingroup$ "Light Path Node -> Is Shadow Ray" - This is GOLD, thank you. You just solved hours of troubleshooting. I also added a "Subtract" node (Anywhere from 0.1 - 0.5) after "Is Shadow Ray" to adjust the shadow. The shadow now degrades as light passes through multiple panes of glass - as it should. $\endgroup$ – gatzkerob Sep 24 at 23:38
6
$\begingroup$

You need to put a solidify modifier on your glass pieces. Or make them thick otherwise.

This way there will be no back-facing polygons for each glass piece, so Cycles doesn't see one huge solid glass pyramid with the inside not empty as it does currently. Such glass pyramid would, in real live, produce this shadow.

$\endgroup$
  • 2
    $\begingroup$ Hi Jerryno, the glasspieces are solidified, so that's not the issue... $\endgroup$ – Christophe May 15 '15 at 16:05
  • $\begingroup$ @Christophe interesting.. what are your transparency bounce settings? can you edit your question and add a screenshot of your nodes or upload the whole file? I was certain the normals were the issue-this is exactly how such glass looks.( $\endgroup$ – Jaroslav Jerryno Novotny May 15 '15 at 16:25
  • $\begingroup$ I added a downloadlink to the file. Thanks for looking at this. Transparency- and shadowsettings in Blender are pretty new to me ... $\endgroup$ – Christophe May 15 '15 at 16:59
2
$\begingroup$

Thank you all for your help!

Apparently there was something wrong with the "Ambient Occlusion". Very strange.

Initial settings 'World'

enter image description here

Result intitial settings and node settings

(so, solid shadows ==> not good)

enter image description here

Change 'World'-settings

==> put 'Ambient Occlusion" ON and OFF again

enter image description here

It worked!

Thank you!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.