30
$\begingroup$


I got a problem with pose mode.
Like the heading says, I haven't found yet a possibility to reset the already transformed armature so that it exactly does look like the rest position (though it is still in pose position).
Is there any kind of shortcuts or tricks to do that?

$\endgroup$
  • 5
    $\begingroup$ Have you tried to select all bones, then hit "ALT+R" to reset all rotations, and "ALT+G" to reset all translations, and "ALT+S" to reset all scales? If you do that and it doesn't return to its rest position, it means you may have errors in the bone constraints (dependency cycle). $\endgroup$ – Polosson May 15 '15 at 10:11
44
$\begingroup$

Select all the bones, in pose mode with A. Then, hit:

  • ALT R to reset all rotations,
  • ALT G to reset all translations,
  • ALT S to reset all scales.

Or, you can select all bones (A) and hit space. Then search for "clear pose" and select Clear Pose Transforms in the results. Et voilà!

$\endgroup$
6
$\begingroup$

Case of the Hidden Bones.

If someone else is finding this problem, the above solution does work except.... If you have some bones hidden from view they will not be selected and therefore they will not be reset. I spent more than an hour and I was only minutes away from flipping my desk when I realized some of the bones were hidden. So unhide those bones and make sure they are part of the selection when you reset everything.

$\endgroup$
  • $\begingroup$ I just had the same issue 😅 $\endgroup$ – Kenmore May 25 at 2:36
  • 1
    $\begingroup$ I had a similar problem where I'd added some IK bones, whose default positions were way off what they should have been, so after clearing all transforms they were stretching everything out like crazy. Had to turn off all IK constraints, then enable and fix them one by one. $\endgroup$ – Rena Jun 30 at 22:11
5
$\begingroup$

In case the above doesn't solve your problem, I found myself having similar issues because I had bones constrained to a pole target and my pole angle was off. I'm not sure why this displays differently in rest mode vs pose mode, and that's what was driving me crazy and acting as a red herring.

$\endgroup$
1
$\begingroup$

I tried to reset rest pose, but there were some contraints missing. It's just a picture of an extrem buggy step in between but, that result could be fixed just with more contraints

There is another issue, which comes up by complex rigs with multiple bones, like arms which have three pairs of bones.

One pair for inverse kinematic, one for forward kinematic and one pair which effects the mesh.

If there are not every bone corectly set with contraints, especialy with copy location contrains, there might be some differences between edit and pose mode.

$\endgroup$
  • $\begingroup$ Are you implying that in such a case there is no definitive rest pose? $\endgroup$ – batFINGER Jul 31 '18 at 10:44
  • $\begingroup$ in such an setup as it was at my complex rig, the bones restet in another location as from edit mode, yes. But I did a extremly complex rig with an DVD Workshop. $\endgroup$ – M. Matz Aug 1 '18 at 13:05
0
$\begingroup$

There is one more solution that might evade a person. The bones must be set to Axis | Angle rather than Quaternion Rotation. This happened to me when exporting from Makehuman 1.1.1 to Blender 2.76b

$\endgroup$
  • $\begingroup$ This answer is not complete. My rigs are posable and resetable regardless of the rotation mode. $\endgroup$ – Leander Jun 6 '18 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.