2
$\begingroup$

I tried to make glass material following a tutorial and faced with problem when setting to a alpha blend mode enter image description here

I have these settings: enter image description hereenter image description here enter image description here

With Opaque mode it seems fine, but I need to have its transparency

Please, if you know how to solve this problem help me :)

$\endgroup$
3
  • $\begingroup$ Hello, you could disable Show Backface but it looks like there's a problem with the handle? Maybe share your file: blend-exchange.com $\endgroup$
    – moonboots
    Dec 28, 2023 at 15:27
  • $\begingroup$ @moonboots hello, thank you for your answer! I tried to remove "Show backface" from the material settings, but is is not exactly that I need. I want to make transparent glass with transparent fluid inside I also pined my project file at the bottom of the question $\endgroup$ Jan 12 at 7:51
  • $\begingroup$ light path components you're using are Cycles only: docs.blender.org/manual/en/latest/render/shader_nodes/input/… $\endgroup$
    – lemon
    Jan 12 at 7:58

1 Answer 1

1
$\begingroup$

You are using Eevee, Eevee has some limitations for glass material, also as long as you are in Cycles but in Material preview you'll still have some limitations. In Eevee, to avoid bad transparency, disable Show Backface for the glass:

enter image description here

As for the liquid if you want to see it through glass you need to disable Screen Space Refraction and make it Opaque:

enter image description here

Result:

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank you! That's it! $\endgroup$ Jan 12 at 11:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .