enter image description hereI can't get the image to apply correctly. I tried UV unwrapping it but I can't get it to work properly. It works fine on a square shaped objects but whenever I try to apply it on an unusual shape objects. The image is distorted.

  • 2
    $\begingroup$ I think we'll need to see your Blend file preferably with just the object which is causing problems in it. You'll also need to pack any image(s) used into the Blend file which you can do via File > External Data > Pack Resources before sharing the blend file. You can share it via blend-exchange.com if it's under 30Meg in size following the instructions there to copy the link on that page and then edit your question here and paste the link into it. $\endgroup$
    – John Eason
    Dec 25, 2023 at 12:37
  • 1
    $\begingroup$ Have you tried different projection methods? I.e. cube project? $\endgroup$ Dec 25, 2023 at 13:29
  • $\begingroup$ Yes i have. And it still doesn't work. I have tried to upload more pictures.To give you a better idea what is going on but for some reason it only letting me upload one picture. $\endgroup$ Dec 25, 2023 at 20:14
  • $\begingroup$ please pack your images (File > External Data > Pack Resources) and share your file $\endgroup$
    – moonboots
    Dec 26, 2023 at 10:21
  • $\begingroup$ Ok, I've found a solution to your problem. Read my updated answer. $\endgroup$
    – Yaroslav
    Dec 27, 2023 at 7:46

1 Answer 1



I've examined the newly added file – and I've found the source of your problem.

The objects in your file are made using Boolean Operations.

Booleans have many side effects and you've experienced one of them:

after objects have been interacted via booleans – the result object inherits BOTH uv-maps.

Non of which does work correctly with the new geometry. That's the reason for many glitches, including the one you've experienced in this case :

enter image description here

To solve this issue you need to delete the old maps [–] and create a new one [+].

After that you can unwrap the object: either automatically (using Smart UV Project) or manually (which is a better option)

I've made the manual unwrapping for you. Now your objects look this way :

enter image description here

You can adjust how the texture applied by moving, rotating and scaling geometry in the uv-editor – it's on the left side of the screenshot here :

enter image description here

(1) Here is the fixed file:

(2) And - since I've completely rewrote my answer - the link to the video about the manual unwrapping I've mentioned before: =VIDEO (link)=


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .