3
$\begingroup$

Please see attached project file. The sim starts at around frame 200, but freezes completely at 726, just after the bowl drops. The entire animation is 900 frames, and the Rigid Body Simulation range is set to 1200. The passive rigid bodies that animate all have "Animation" turned on. Why is it freezing? Things I've tried:

  • Deleted sim cache and toggled Gravity
  • Played with various simulation ranges
  • Played with various Substeps per frame
  • Played with various Solver iterations
  • Added turbulence at the point where they freeze, in hopes of activating some kind of response

This issue has delayed me an entire day, any help is appreciated!

Project File

$\endgroup$

1 Answer 1

4
$\begingroup$

it's because you are disabling rigid body via keyframe at frame 728

enter image description here

so either move the keyframes or keyframe "dynamic" again, then delete the cache and bake again.

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ wow i'm such an idiot haha. thanks so much!! I totally forgot that i did that. I'm coming from C4D and was starting to get frustrated that the dynamics solver wasn't as stable. But as always there is a simple answer and I'm loving Blender 100%. Thanks for the quick response! $\endgroup$
    – sakeferret
    Dec 21, 2023 at 15:12
  • $\begingroup$ you are welcome! $\endgroup$
    – Chris
    Dec 21, 2023 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .