0
$\begingroup$

I have a rabbit that goes wrong when exporting fbx or gltb. It looks fine in blender but very wrong during exporting with animations. anyone knows why and how to fix it? I have tried bake action, bake ik, new rig with constraints pose, apply modifier before exporting, apply transform, re-parent mesh... scale is 1. rig uses rigify. here are some photos, I can send videos and the file too.

My first blender modeling, rigging and animation... dying to know where i did wrong :(

Thank you.. files download until 2023.12.27 https://we.tl/t-0YLM18pPWw

before and after

looks fine in blender

looks weird after exporting

$\endgroup$
6
  • $\begingroup$ Please include the export settings and the program to which you are importing the FBX to. $\endgroup$ Dec 18, 2023 at 20:05
  • $\begingroup$ ibb.co/t21R02X ibb.co/YfpHRVk $\endgroup$
    – rangyouya
    Dec 19, 2023 at 12:48
  • $\begingroup$ The Apply Modifiers option will apply your Armature modifier. try turning that export option off. $\endgroup$ Dec 19, 2023 at 14:02
  • $\begingroup$ yes i have tried, same result :( $\endgroup$
    – rangyouya
    Dec 19, 2023 at 14:16
  • $\begingroup$ Please edit your question above and include the BLEND file, the exported FBX file and the name of the program in which your are importing the FBX. $\endgroup$ Dec 19, 2023 at 14:22

1 Answer 1

1
$\begingroup$

After inspecting your blend file I've come to the following conclusion.

The cause of unwanted deformations is the presence of Stretch To Constraint on some of your Deform bones. If you use Blender 4.0 they will be located in Layer 30.

Unfortunately this constraint has an option to maintain the objects volume when stretched which unfortunately cannot be translated perfectly to just bone scale keys. However it seems the exporter attempts to compensate for that option which causes undesirable result.

With this Constraint available there is no perfect solution but the best you can do is to set the Maintain Volume to None to all deforming bones

enter image description here

Deforming bones in Layer 30, set Maintain Volume to None to all Stretch To constraints in that layer.

Your FBX export settings are fine and with the above recommendation you will get the following import back in Blender:

enter image description here

Unfortunately you can't get the exact result back due to the nature of the Stretch To constraint, which is now missing in the FBX import.

Alternatively, You can try correcting the animations of the character with disabled / removed / Stretch To constraints from the deform bones.

$\endgroup$
2
  • $\begingroup$ Thank you so much for looking at all the files and detailed suggestions! It helps and means a lot! I will take a look into it. Merry Christmas! : ) $\endgroup$
    – rangyouya
    Dec 21, 2023 at 12:52
  • $\begingroup$ You are very welcome. Merry Christmas! $\endgroup$ Dec 21, 2023 at 13:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .